• [UVa] Palindromes(401)


    UVA - 401
    Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

     Status

    Description

    A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.


    A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others' reverses.


    A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA"is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string.

    Of course,"A","T", "O", and "Y" are all their own reverses.

    A list of all valid characters and their reverses is as follows.

    Character Reverse Character Reverse Character Reverse
    A A M M Y Y
    B   N   Z 5
    C   O O 1 1
    D   P   2 S
    E 3 Q   3 E
    F   R   4  
    G   S 2 5 Z
    H H T T 6  
    I I U U 7  
    J L V V 8 8
    K   W W 9  
    L J X X    


    Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

    Input

    Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

    Output

    For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

    STRING CRITERIA
    " -- is not a palindrome." if the string is not a palindrome and is not a mirrored string
    " -- is a regular palindrome." if the string is a palindrome and is not a mirrored string
    " -- is a mirrored string." if the string is not a palindrome and is a mirrored string
    " -- is a mirrored palindrome." if the string is a palindrome and is a mirrored string

    Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

    In addition, after each output line, you must print an empty line.

    Sample Input

    NOTAPALINDROME 
    ISAPALINILAPASI 
    2A3MEAS 
    ATOYOTA

    Sample Output

    NOTAPALINDROME -- is not a palindrome.
     
    ISAPALINILAPASI -- is a regular palindrome.
     
    2A3MEAS -- is a mirrored string.
     
    ATOYOTA -- is a mirrored palindrome.

    Hint

    use the C++'s class of string will be convenient, but not a must

    ac代码:

    #include <cstdio>
    #include <cstring>
    #include <cctype>
    #define MAX 30  // 最大字符长度 
    const char* rev = "A   3  HIL JM O   2TUVWXY51SE Z  8 ";// 用于存储对应字母的镜像字符,如果没有就用' '表示 
    const char* msg[] = {"is not a palindrome.","is a regular palindrome.","is a mirrored string.","is a mirrored palindrome."};
    // 用于存放要发出的讯息字符串 
    
    char r(char r){
        /* 这个函数他返回对应字符的镜像字符
        如果这个字符是数字,其镜像字符在rev数组中的0到25
        如果这个字符是数字,其镜像字符在26到最后 
        */
        if(isalpha(r)) return rev[r - 'A']; 
        else return rev[r - '0' + 25];
    }
    
    int main(){
        char str[MAX];
        while(scanf("%s", str) == 1) { // 不包含空白字符,可以用scanf直接输入,scanf返回按照格式控制符成功读入数据的个数 
            int len = strlen(str);
            int p = 1, m = 1;
            for(int i = 0; i < (len + 1) / 2; i++){
                if(str[i] != str[len - 1 - i]) p = 0; // 此时str不为回文串,输出的信息为msg中的0,2
                if(r(str[i]) != str[len - 1 - i]) m = 0; // 此时str不为镜像串,输出内容为msg中的0, 2 
            }
            printf("%s -- %s
    
    ", str, msg[m * 2 + p]);
        } 
        return 0;
    } 

    提交了三次才过去,就是在确认内循环终点那里有问题啊,应该是(len + 1 )/ 2的,写成了len / 2。这真的是:)

  • 相关阅读:
    糍粑大叔的独游之旅-战斗!之弹道实现
    攻击判定流程研究: 瀑布算法、圆桌算法、混合算法解析
    GitHub排名TOP30的机器学习开源项目/贪心学院
    学习ES7+ES8
    k8s Ipvs 内部网络自动分配和内部网络一致ip地址,导致ip冲突
    Linux操作系统load average过高,kworker占用较多cpu
    chrome断点调试&&其他技巧
    Mongodb更新数组$pull修饰符 (mongodb 修改器($inc/$set/$unset/$push/$pop/upsert))
    记一次线上Java程序导致服务器CPU占用率过高的问题排除过程
    解决并发问题,数据库常用的两把锁(转)
  • 原文地址:https://www.cnblogs.com/MATLABlearning001/p/5572876.html
Copyright © 2020-2023  润新知