• POJ:2377-Bad Cowtractors


    传送门:http://poj.org/problem?id=2377

    Bad Cowtractors

    Time Limit: 1000MS Memory Limit: 65536K
    Total Submissions: 17373 Accepted: 7040

    Description

    Bessie has been hired to build a cheap internet network among Farmer John’s N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn’t even want to pay Bessie.

    Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a “tree”.

    Input

    • Line 1: Two space-separated integers: N and M

    • Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

    Output

    • Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

    Sample Input

    5 8
    1 2 3
    1 3 7
    2 3 10
    2 4 4
    2 5 8
    3 4 6
    3 5 2
    4 5 17

    Sample Output

    42

    Hint

    OUTPUT DETAILS:

    The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.


    解题心得:

    1. 求一个最”大“生成树,裸的。

    #include <stdio.h>
    #include <algorithm>
    #include <cstring>
    using namespace std;
    typedef long long ll;
    const int maxn = 2e4+100;
    
    int n,m,father[1010];
    struct Path {
        int s,e,len;
        bool operator < (const Path & a) const {
            return a.len < len;
        }
    }path[maxn];
    
    void init() {
        for(int i=1;i<=n;i++)
            father[i] = i;
        for(int i=0;i<m;i++) {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            path[i].s = a, path[i].e = b, path[i].len = c;
        }
        sort(path,path+m);
    }
    
    int find(int x) {
        if(father[x] == x)
            return x;
        return father[x] = find(father[x]);
    }
    
    void merge(int x,int y) {
        int fx = find(x);
        int fy = find(y);
        if(fx != fy)
            father[fx] = fy;
    }
    
    int main() {
        scanf("%d%d",&n,&m);
        init();
        ll ans = 0;
        for(int i=0;i<m;i++) {
            if(find(path[i].s) != find(path[i].e)) {
                ans += path[i].len;
                merge(path[i].s,path[i].e);
            }
        }
        int cnt = 0;
        for(int i=1;i<=n;i++)
            if(father[i] == i)
                cnt++;
        if(cnt >= 2)
            ans = -1;
    
        printf("%d",ans);
        return 0;
    }
  • 相关阅读:
    Spring DI模式 小样例
    java中经常使用的日期格式化(全)
    循环-15. 统计素数并求和(20)
    [Unity3D]Unity3D游戏开发之自己主动寻路与Mecanim动画系统的结合
    【UVA】11732
    Mac OS使用技巧之十六:系统失去响应怎么办?
    C# 保存窗口为图片(保存纵断面图)
    Linux Resin 安装
    Etcd学习(二)集群搭建Clustering
    android中选择控件与选择界面自然过度效果的实现--一种新的交互设计
  • 原文地址:https://www.cnblogs.com/GoldenFingers/p/9107144.html
Copyright © 2020-2023  润新知