• POJ 2312:Battle City(BFS)


                                                Battle City

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 9885   Accepted: 3285

    Description

    Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 


    What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 


    Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

    Input

    The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

    Output

    For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

    Sample Input

    3 4
    YBEB
    EERE
    SSTE
    0 0
    

    Sample Output

    8

    题意

    n*m的矩阵,Y代表起点,T代表终点,R不能通过,走E需要一步,B需要两步。求从起点到终点的最短距离。如果不能到达,输出-1

    AC代码

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <math.h>
    #include <limits.h>
    #include <map>
    #include <stack>
    #include <queue>
    #include <vector>
    #include <set>
    #include <string>
    #define ll long long
    #define ms(a) memset(a,0,sizeof(a))
    #define pi acos(-1.0)
    #define INF 0x3f3f3f3f
    const double E=exp(1);
    const int maxn=1e3+10;
    char ch[maxn][maxn];
    using namespace std;
    int place[5][2]={1,0,-1,0,0,1,0,-1};
    int vis[maxn][maxn];
    int n,m;
    struct node
    {
    	int x,y,dis;
    };
     bool operator < (const node a,const node b)
    {
    	return a.dis>b.dis;
    }
    void bfs(int a,int b,int c,int d)
    {
    	ms(vis);
    	vis[a][b]=1;
    	priority_queue<node> que;
    	node start,end;
    	start.x=a;
    	start.y=b;
    	start.dis=0;
    	que.push(start);
    	int ans=-1;
    	while(!que.empty())
    	{
    		start=que.top();
    		que.pop();
    		if(start.x==c&&start.y==d)
    		{
    			ans=start.dis;
    			break;
    		}
    		for(int i=0;i<4;i++)
    		{
    			end.x=start.x+place[i][0];
    			end.y=start.y+place[i][1];
    			if(ch[end.x][end.y]=='R'||ch[end.x][end.y]=='S')
    				continue;
    			if(end.x<0||end.x>=n||end.y<0||end.y>=m)
    				continue;
    			if(vis[end.x][end.y])
    				continue;
    			if(ch[end.x][end.y]=='E'||ch[end.x][end.y]=='T')
    				end.dis=start.dis+1;
    			if(ch[end.x][end.y]=='B')
    				end.dis=start.dis+2;
    			que.push(end);
    			vis[end.x][end.y]++;	
    		}
    	}
    	cout<<ans<<endl;
    }
    int main(int argc, char const *argv[])
    {
    	ios::sync_with_stdio(false);
    	while(cin>>n>>m)
    	{
    		if(n==0&&m==0)
    			break;
    		ms(vis);
    		ms(ch);
    		int x1,x2,y1,y2;
    		for(int i=0;i<n;i++)
    			cin>>ch[i];
    		for(int i=0;i<n;i++)
    		{
    			for(int j=0;j<m;j++)
    			{
    				if(ch[i][j]=='Y') {x1=i;y1=j;}
    				if(ch[i][j]=='T') {x2=i;y2=j;}
    			}
    		}
    		bfs(x1,y1,x2,y2);	
    	}
    	return 0;
    }
    
  • 相关阅读:
    redis list 清空记录小技巧
    fastJson 之 JSONPath使用
    【移动开发】怎样自己定义ViewGroup
    POJ 3255 Roadblocks
    java带图片的邮件发送方法实现
    android学习二(Activity)
    OpenWRT加入 crontab开机默认运行
    ubuntu14.04启动提示set_sw_state failed
    jekyll bootstrap更改主题theme
    windows API 实现截图
  • 原文地址:https://www.cnblogs.com/Friends-A/p/10324430.html
Copyright © 2020-2023  润新知