Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9532 Accepted Submission(s): 6722
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
10
20
Sample Output
5
42
627
42
627
Author
Ignatius.L
1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 5 using namespace std; 6 7 const int maxn=200; 8 9 int c1[maxn],c2[maxn]; 10 11 int main() 12 { 13 int n; 14 while(scanf("%d",&n)!=EOF) 15 { 16 for(int i=0;i<=n;i++) 17 { 18 c1[i]=1; c2[i]=0; 19 } 20 21 for(int i=2;i<=n;i++) 22 { 23 for(int j=0;j<=n;j++) 24 { 25 for(int k=0;j+k<=n;k+=i) 26 c2[k+j]+=c1[j]; 27 } 28 29 for(int j=0;j<=n;j++) 30 { 31 c1[j]=c2[j]; c2[j]=0; 32 } 33 } 34 printf("%d ",c1[n]); 35 } 36 37 return 0; 38 }