• PAT Advanced Level 1064 Complete Binary Search Tree (30)(30 分)


    1064 Complete Binary Search Tree (30)(30 分)

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0

    Sample Output:

    6 3 8 1 5 7 9 0 2 4
    题解总是好使的,看了题解我一拍大腿,我怎么就没想到!!!

    /**********************
    author: yomi
    date: 18.8.18
    ps:
    **********************/
    #include <iostream>
    #include <cmath>
    #include <algorithm>
    
    using namespace std;
    const int maxn = 1010;
    int CBT[maxn], s[maxn], cnt = 1, n;
    void in(int index)
    {
        if(index >  n)
            return;
        in(2*index);
        CBT[index] = s[cnt++];
        in(2*index+1);
    
    }
    int main()
    {
        cin >> n;
        for(int i=1; i<=n; i++){
            cin >> s[i];
        }
        sort(s+1, s+n+1);
        in(1);
        for(int i=1; i<n; i++){
            cout << CBT[i] << ' ';
        }
        cout << CBT[n];
        return 0;
    }
    /**
    Sample Input:
    10
    1 2 3 4 5 6 7 8 9 0
    Sample Output:
    6 3 8 1 5 7 9 0 2 4
    **/
     
  • 相关阅读:
    ABB机器人 带参数例行程序
    面试题10- I:斐波那契数列(C++)
    面试题39:数组中出现次数超过一半的数字(C++)
    面试题50:第一个只出现一次的字符(C++)
    第八部分 表的基本操作
    第七部分 表中数据的基本操作
    面试题18:删除链表的节点(C++)
    面试题35:复杂链表的复制(C++)
    面试题54:二叉搜索树的第k大节点(C++)
    面试题62:圆圈中最后剩下的数字(C++)
  • 原文地址:https://www.cnblogs.com/AbsolutelyPerfect/p/9501583.html
Copyright © 2020-2023  润新知