• Speed Limit


    Description

    Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don't know how many miles they have driven. Fortunately, Bill has a working stopwatch, so they can record their speed and the total time they have driven. Unfortunately, their record keeping strategy is a little odd, so they need help computing the total distance driven. You are to write a program to do this computation.

    For example, if their log shows
    Speed in miles perhour Total elapsed time in hours
    20 2
    30 6
    10 7

    this means they drove 2 hours at 20 miles per hour, then 6-2=4 hours at 30 miles per hour, then 7-6=1 hour at 10 miles per hour. The distance driven is then (2)(20) + (4)(30) + (1)(10) = 40 + 120 + 10 = 170 miles. Note that the total elapsed time is always since the beginning of the trip, not since the previous entry in their log.

    Input

    The input consists of one or more data sets. Each set starts with a line containing an integer n, 1 <= n <= 10, followed by n pairs of values, one pair per line. The first value in a pair, s, is the speed in miles per hour and the second value, t, is the total elapsed time. Both s and t are integers, 1 <= s <= 90 and 1 <= t <= 12. The values for t are always in strictly increasing order. A value of -1 for n signals the end of the input.

    Output

    For each input set, print the distance driven, followed by a space, followed by the word "miles"

    Sample Input

    3
    20 2
    30 6
    10 7
    2
    60 1
    30 5
    4
    15 1
    25 2
    30 3
    10 5
    -1
    

    Sample Output

    170 miles
    180 miles
    90 miles






    #include <iostream>
    using namespace std;
    int main()
    {
    
    int n,a[100][2],i;
    a[0][1]=0;
    while(cin>>n,n!=-1)
    {int sum=0;
    	for(i=1;i<=n;i++){
    cin>>a[i][0]>>a[i][1];
    sum=sum+a[i][0]*(a[i][1]-a[i-1][1]);
    }
    cout<<sum<<" miles"<<endl;
    
    
    
    }
    
    
    return 0;}


     
  • 相关阅读:
    hdu 1174
    计算几何模板
    又是一年博客记
    hdu 1225 Football Score
    与逆序数有关的
    hdu 2844 Coins
    hdu 1171 Big Event in HDU
    UVA Exponentiation
    UVA Summation of Four Primes
    Linux:设置alias永久生效
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387846.html
Copyright © 2020-2023  润新知