• PAT 1125 Chain the Ropes


    Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

    rope.jpg

    Your job is to make the longest possible rope out of N given segments.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10^​4 ). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10^​4 .

    Output Specification:

    For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

    Sample Input:

    8
    10 15 12 3 4 13 1 15

    Sample Output:

    14

    #include<iostream> //水题
    #include<vector>
    #include<algorithm>
    using namespace std;
    int main(){
    	int n, ans=0;
    	cin>>n;
    	vector<int> data(n, 0);
    	for(int i=0; i<n; i++)
    		cin>>data[i];
    	sort(data.begin(), data.end());
    	ans=data[0];
    	for(int i=1; i<n; i++)
    		ans=(ans+data[i])/2;
    	cout<<ans<<endl;
    	return 0;
    } 
    
  • 相关阅读:
    Ajax
    Linux安装SmartSVN及破解
    JQuery异步提交
    动画效果
    事件
    表单选择器
    DOM操作
    JQuery基础
    PHP环境配置
    DP--钢条切割
  • 原文地址:https://www.cnblogs.com/A-Little-Nut/p/9506514.html
Copyright © 2020-2023  润新知