• 7-17 Hashing(25 分) 整型关键字的平方探测法散列


    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (104​​) and N (MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

    Sample Input:

    4 4
    10 6 4 15
    

    Sample Output:

    0 1 4 -
    

    平方探测法。

    代码:
    #include <cstdio>
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <map>
    using namespace std;
    int is(int n)
    {
        if(n == 1)return 0;
        if(n == 2 || n == 3)return 1;
        if(n % 6 != 1 && n % 6 != 5)return 0;
        for(int i = 5;i * i <= n;i += 6)
        {
            if(n % i == 0 || n % (i + 2) == 0)return 0;
        }
        return 1;
    }
    int main()
    {
        int m,n;
        int s,p,v[10007] = {0};
        scanf("%d %d",&m,&n);
        while(!is(m))m ++;
        for(int i = 0;i < n;i ++)
        {
            p = -1;
            scanf("%d",&s);
            for(int j = 0;j < m;j ++)
            {
                if(!v[(s + j * j) % m])
                {
                    v[(s + j * j) % m] = 1;
                    p = (s + j * j) % m;
                    break;
                }
            }
            if(i)putchar(' ');
            if(p == -1)printf("-");
            else printf("%d",p);
        }
    }
  • 相关阅读:
    bzoj 4260 Codechef REBXOR——trie树
    bzoj 2238 Mst——树链剖分
    bzoj 2836 魔法树——树链剖分
    CF 888E Maximum Subsequence——折半搜索
    bzoj 4289 PA2012 Tax——构图
    bzoj 4398 福慧双修——二进制分组
    bzoj1116 [POI2008]CLO——并查集找环
    bzoj4241 历史研究——分块
    bzoj4373 算术天才⑨与等差数列——线段树+set
    bzoj4034 [HAOI2015]树上操作——树链剖分
  • 原文地址:https://www.cnblogs.com/8023spz/p/7746524.html
Copyright © 2020-2023  润新知