• HDU Windows Message Queue


    Windows Message Queue

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1686    Accepted Submission(s): 637


    Problem Description
    Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
     
    Input
    There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
     
    Output
    For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
     
    Sample Input
    GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET
     
    Sample Output
    EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!
     
    Author
    ZHOU, Ran
     
    Source
     
    Recommend
    linle
     
     http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2724
    //优先队列练习
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <queue>
    #include <vector>
    using namespace std;
    struct node
    {
        char s[100];
        int n;
        int p;
        int i;
    };
    struct cmp
    {
        bool operator ()(const node&a,const node&b)
        {
            if(a.p==b.p)
            {
                return a.i>b.i;
            }
            return a.p>b.p;
        }
    };
    int main()
    {
        node t;
        priority_queue<node,vector<node>,cmp> Q;
        char s[5];
        int k=1;
        while(scanf("%s",s)!=EOF)
        {
            if(s[0]=='G')
            {
                if(!Q.empty())
                {
                    t=Q.top();
                    Q.pop();
                    printf("%s %d\n",t.s,t.n);
                }
                else
                  printf("EMPTY QUEUE!\n");//开始时这忘记写'!'符号,贡献了次WA
            }
            else
            {
               scanf("%s%d%d",t.s,&t.n,&t.p);
                 t.i=k++;
               Q.push(t);
            }
        }
        return 0;
    }

  • 相关阅读:
    名字 地址 路由
    截断二进制指数退避
    硬件地址 软件地址
    基带信号 调制
    非对称数字用户线
    码分复用 码分多址
    时分复用 帧长度
    多模光纤 单模光纤
    码间串扰 奈氏准则 香农公式
    flask 文件下载 文件服务器 请求参数 函数修饰符
  • 原文地址:https://www.cnblogs.com/372465774y/p/2581530.html
Copyright © 2020-2023  润新知