• bzoj1650:跳石子


    1650: [Usaco2006 Dec]River Hopscotch 跳石子

    Time Limit: 5 Sec  Memory Limit: 64 MB
    Submit: 345  Solved: 230
    [Submit][Status][Discuss]

    Description

    Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 <= L <= 1,000,000,000). Along the river between the starting and ending rocks, N (0 <= N <= 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L). To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river. Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 <= M <= N). FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

    数轴上有n个石子,第i个石头的坐标为Di,现在要从0跳到L,每次条都从一个石子跳到相邻的下一个石子。现在FJ允许你移走M个石子,问移走这M个石子后,相邻两个石子距离的最小值的最大值是多少。

    Input

    * Line 1: Three space-separated integers: L, N, and M * Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

    Output

    * Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

    Sample Input

    25 5 2
    2
    14
    11
    21
    17

    5 rocks at distances 2, 11, 14, 17, and 21. Starting rock at position
    0, finishing rock at position 25.

    Sample Output

    4

    HINT

       移除之前,最短距离在位置2的石头和起点之间;移除位置2和位置14两个石头后,最短距离变成17和21或21和25之间的4.

    Source

    Silver

    还是二分答案

    d--------------------------------------------------------------------------------

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    #include<deque>
    using namespace std;
    const int nmax=50005;
    int a[nmax];
    int n,m,k,ans;
    int pd(int x){
        int tmp=0;
        int cur=0;
        for(int i=1;i<=n;i++){
            if(a[i]-a[cur]<x){
                 tmp++;
                  if(tmp>k) return 0;
              }
             else
                   cur=i;
     }
     return 1;
    }
    int main(){
         scanf("%d%d%d",&m,&n,&k);
         for(int i=1;i<=n;i++){
               scanf("%d",&a[i]);
           }
         sort(a+1,a+n+1);
         a[0]=0;
         a[++n]=m;
         int l=0;int r=m;
         while(l<=r){
              int m=(l+r)/2;
              if(pd(m)){
                   ans=m;
                   l=m+1;
              }
              else
                  r=m-1;
          }
           printf("%d ",ans);
           return 0;
    }

    ---------------------------------------------------------------------------------

  • 相关阅读:
    linux学习笔记----权限与命令之间的关系(极重要)
    linux学习笔记----文件与目录管理
    Linux文件权限与目录配置
    linux:基本命令
    Java:正则表达式
    SDIBT 3237 Boring Counting( 划分树+二分枚举 )
    山东省第四届ACM大学生程序设计竞赛解题报告(部分)
    poj 3522 Slim Span (最小生成树kruskal)
    poj 1236 Network of Schools(又是强连通分量+缩点)
    poj 2762 Going from u to v or from v to u?(强连通分量+缩点重构图+拓扑排序)
  • 原文地址:https://www.cnblogs.com/20003238wzc--/p/4817701.html
Copyright © 2020-2023  润新知