• 每日一九度之 题目1043:Day of Week


    时间限制:1 秒

    内存限制:32 兆

    特殊判题:

    提交:7336

    解决:2563

    题目描述:

    We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
    For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
    Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

    输入:

    There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

    输出:

    Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

    样例输入:
    9 October 2001
    14 October 2001
    
    样例输出:
    Tuesday
    Sunday
    提示:

    Month and Week name in Input/Output:
    January, February, March, April, May, June, July, August, September, October, November, December
    Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday

    已知年月日,计算星期的公式有两个,一个是蔡勒公式,另一个就是基姆拉尔森计算公式。

    具体的我也就不写了,大家可以百度。O(∩_∩)O哈哈~

    我用的是基姆拉尔森计算公式。可以试着用蔡勒公式做下。但是那个比这个麻烦一点,因为还要计算出世纪c。

    //Asimple
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #include <cctype>
    #include <cstdlib>
    #include <stack>
    #include <cmath>
    #include <set>
    #include <map>
    #include <string>
    #include <queue>
    #include <limits.h>
    #define INF 0x7fffffff
    using namespace std;
    const int maxn = 115;
    typedef long long ll;
    int year, days;
    string moths[] = {"January", "February", "March",   
                        "April", "May", "June",   
                        "July", "August", "September",   
                        "October", "November", "December"};
    string str;
    string weeks[]={"Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday","Sunday"};
    
    int main(){
        while( cin >> days >> str >> year ){
            int m;
            for(int i=0; i<13; i++){
                if( str == moths[i] ){
                    m = i + 1;
                    break;
                }
            }
            if( m == 1 || m == 2 ){
                m += 12;
                year --;
            }
            int a = (days + 2 * m + 3 * (m + 1) / 5 + year + year / 4 - year / 100 + year / 400) % 7;
            cout << weeks[a] << endl;
        } 
        return 0;
    }
    低调做人,高调做事。
  • 相关阅读:
    springboot的自动配置
    tomcat8.5和redis实现session共享
    GitHub提交时出错,提示需要验证邮箱verify email
    vue3可拖拽容器宽度
    vue解决iOS10-11、vant部分版本ImagePreview点击预览图片无法缩放回去的问题
    使用vue自定义指令限制input输入内容为正整数
    判断当前时间是否超出预约(配送)时间
    vue选择地址字母联动
    手机号码中间四位*号隐藏(别的方法有的机型不适配)
    前端面试题
  • 原文地址:https://www.cnblogs.com/Asimple/p/5896342.html
Copyright © 2020-2023  润新知