• PAT1007:Maximum Subsequence Sum


    1007. Maximum Subsequence Sum (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:
    10
    -10 1 2 3 4 -5 -23 3 7 -21
    
    Sample Output:
    10 1 4

    思路

    DP的思想。
    这道题最关键点在于:确定最大值子序列的左右索引left和right。那么:
    1.从左到右遍历序列时,如果遍历到第i个数时的累加和已经小于0,那么说明从这个数左边开始的所有可能的左半部序列到这个数的和都已经小于0,对于这个数右半部分的序列只减不增,还不如舍弃掉。因此最大和子序列肯定只会在这个数右边。所以暂存下新的左索引templeft = i + 1。
    2.当遍历到第i个数时当前最大值tempsum已经大于输出最大值maxsum时,maxsum = tempsum,那么需要更新左右索引left = templeft 和 right = i.
    3.对于遍历后maxsum < 0,说明整个序列只可能全是负数,不存在最大正数和的情况,根据题目要求令maxsum = 0,左右索引即为元序列的左右索引。

    代码
    #include<iostream>
    #include<vector>
    using namespace std;
    int main()
    {
        int N;
        while(cin >> N)
        {
          vector<int> nums(N);
          int left = 0,right = N - 1,maxsum = -233,tempsum = 0,templeft = 0;
          for(int i = 0;i < N;i++)
          {
              cin >> nums[i];
              tempsum += nums[i];
              if(tempsum < 0)
              {
                  tempsum = 0;
                  templeft = i + 1;
              }
              else if (tempsum > maxsum)
              {
                  left = templeft;
                  maxsum = tempsum;
                  right = i;
              }
    
          }
          if(maxsum < 0)
            maxsum = 0;
          cout << maxsum << " " << nums[left] << " " << nums[right] << endl;
        }
    }
  • 相关阅读:
    python数据处理——numpy_2
    Python数据处理——numpy_1
    MyEclipse 6.5 代码单词自动提示设置方法
    c语言 标准输入与输出
    JAVA中的NullPointerException异常
    c语言memmove()
    c语言 isalpha,isdigit,islower,isupper,isalnum等一系列函数
    c语言fflush()
    c语言 多维数组与指针
    c语言 回车符和换行符
  • 原文地址:https://www.cnblogs.com/0kk470/p/7643173.html
Copyright © 2020-2023  润新知