• POJ3664


    The cows are having their first election after overthrowing the tyrannical Farmer John, and Bessie is one of N cows (1 ≤ N ≤ 50,000) running for President. Before the election actually happens, however, Bessie wants to determine who has the best chance of winning.

    The election consists of two rounds. In the first round, the K cows (1 ≤ K ≤N) cows with the most votes advance to the second round. In the second round, the cow with the most votes becomes President.

    Given that cow i expects to get Ai votes (1 ≤ Ai ≤ 1,000,000,000) in the first round and Bi votes (1 ≤ Bi ≤ 1,000,000,000) in the second round (if he or she makes it), determine which cow is expected to win the election. Happily for you, no vote count appears twice in the Ai list; likewise, no vote count appears twice in the Bi list.

    Input

    * Line 1: Two space-separated integers: N and K 
    * Lines 2..N+1: Line i+1 contains two space-separated integers: Ai and Bi

    Output

    * Line 1: The index of the cow that is expected to win the election.

    Sample Input

    5 3
    3 10
    9 2
    5 6
    8 4
    6 5
    

    Sample Output

    5
    两次排序
    代码
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #define maxn 20020
    
    using namespace std;
    struct node{
        int a,b,num;
    }w[50010+10];
    bool cmp(node X,node Y)
    {
        return X.a>Y.a;
    }
    
    int main()
    {
        int n,k;
        while(~scanf("%d%d",&n,&k))
        {
            for(int i=0;i<n;i++)
            {
                scanf("%d%d",&w[i].a,&w[i].b);
                w[i].num=i+1;
            }
            sort(w,w+n,cmp);
            int Max = -1,ans;
            for(int i=0;i<k;i++)
            {
                if(Max<w[i].b)
                {
                    Max=w[i].b;
                    ans=w[i].num;
                }
            }
            cout <<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    js数组的迭代
    js检测对象的类型
    java基本数据类型及相互间的转换
    Mybatis Jdbctype JavaType 类型转换器
    Android TableLayout
    android:id设置的三种方式区别在哪?
    android:layout_gravity 和 android:gravity 的区别
    Android LinearLayout
    Log4j 分别使用不同的配置文件
    Extjs GridPanel 中放入 Combox显示问题
  • 原文地址:https://www.cnblogs.com/--lr/p/6716101.html
Copyright © 2020-2023  润新知