• PAT L2-005 集合相似度


    https://pintia.cn/problem-sets/994805046380707840/problems/994805070149828608

    给定两个整数集合,它们的相似度定义为:/。其中Nc​​是两个集合都有的不相等整数的个数,Nt​​是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度。

    输入格式:

    输入第一行给出一个正整数N(≤),是集合的个数。随后N行,每行对应一个集合。每个集合首先给出一个正整数M(≤),是集合中元素的个数;然后跟M个[区间内的整数。

    之后一行给出一个正整数K(≤),随后K行,每行对应一对需要计算相似度的集合的编号(集合从1到N编号)。数字间以空格分隔。

    输出格式:

    对每一对需要计算的集合,在一行中输出它们的相似度,为保留小数点后2位的百分比数字。

    输入样例:

    3
    3 99 87 101
    4 87 101 5 87
    7 99 101 18 5 135 18 99
    2
    1 2
    1 3
    

    输出样例:

    50.00%
    33.33%



    时间复杂度:$O(N * K * log(M))$

    题解:二叉搜索树 用 $set$ 容器

    代码:

    #include <bits/stdc++.h>
    using namespace std;
    
    int n;
    set<int> u[55];
    
    void f(int a,int b) {
        int same = 0;
        set<int>::iterator it;
        for(it = u[a].begin(); it != u[a].end(); it ++){
            if(u[b].find(*it) != u[b].end())
                same ++;
        }
        int sum = u[a].size() + u[b].size();
        int cnt = sum - same;
        printf("%.2lf", same * 1.0 / cnt * 100);
        cout<<"%"<<endl;
    }
    
    int main(){
        scanf("%d", &n);
        int k;
        int a;
        int m;
        for(int i = 1; i <= n; i ++) {
            scanf("%d", &k);
            for(int j = 1; j <= k; j ++) {
                scanf("%d", &a);
                u[i].insert(a);
            }
        }
        scanf("%d", &m);
        int b;
        for(int i = 1; i <= m; i ++){
            scanf("%d%d", &a, &b);
    
            f(a,b);
        }
    }
    

      

  • 相关阅读:
    sed命令
    python常用库
    python标准库
    从 Python 打包到 CLI 工具
    pip
    python包自我理解
    docker常用命令
    chattr命令
    xmss
    live2d-widget.js
  • 原文地址:https://www.cnblogs.com/zlrrrr/p/9559586.html
Copyright © 2020-2023  润新知