• HDU 2019 *数列有序!


    http://acm.hdu.edu.cn/showproblem.php?pid=2019

    Problem Description

    有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序。
     
    Input
    输入数据包含多个测试实例,每组数据由两行组成,第一行是n和m,第二行是已经有序的n个数的数列。n和m同时为0标示输入数据的结束,本行不做处理。
     
    Output
    对于每个测试实例,输出插入新的元素后的数列。
     
    Sample Input
    3 3
    1 2 4
    0 0
     
    Sample Output
    1 2 3 4
     
    题解:把 m 存到数组 a[n+1] 的位置再对新的数组进行排序
     
    代码:
    #include <bits/stdc++.h>
    
    using namespace std;
    
    int a[111];
    
    int main()
    {
        int n,m;
        while(cin>>n>>m)
        {
            if(n==0&&m==0)
                break;
            for(int i=1;i<=n;i++)
            {
                cin>>a[i];
            }
             a[n+1]=m;
             for(int j=n+1;j>=2;j--)
             {
                 if(a[j]<=a[j-1])
                    swap(a[j],a[j-1]);
             }
             for(int i=1;i<=n+1;i++)
             {
                 if(i!=n+1)
                    cout<<a[i]<<" ";
                 else
                    cout<<a[i]<<endl;
             }
        }
        return 0;
    }
    

      

  • 相关阅读:
    [BZOJ 2821] 作诗
    [P1084] 疫情控制
    [BZOJ 2243] 染色
    Session
    Jinja2 及 render_template 的深度用法
    request机制
    三件套
    初识flask
    mysql大法
    liunx命令大全
  • 原文地址:https://www.cnblogs.com/zlrrrr/p/9219599.html
Copyright © 2020-2023  润新知