• Counting Sheep


    • Counting Sheep
    • 题目描述:
    • 共有n(n<=20)组数据,其中每组数据有一个正整数m(m<=10),然后是m个单词,统计其中有多少个“sheep”。单词大小写敏感,因而“sheep”等不匹配。
    • 输入样例:
    • 4
    • 5
    • shep sheep sheep ship Sheep
    • 7
    • sheep sheep SHEEP sheep shepe shemp seep
    • 10
    • sheep sheep sheep sheep sheep sheep sheep sheep sheep sheep
    • 4
    • shape buffalo ram goat
    • 输出样例:
    • Case 1:This list contains 1 sheep.
    • Case 2:This list contains 3 sheep.
    • Case 3:This list contains 10 sheep.
    • Case 4:This list contains 0 sheep.

    参考答案:

    #include<iostream>
    #include<string>
    using namespace std;
    int main(){
        int n,m,c = 1,count;
        string str;
        cin>>n;
        while(n--){
            if(c > 1) cout<<endl;   //相邻两行之间输出一个空行 
            cin>>m;     //输入没次输入的单词数 
            count = 0;      //计数器,记录输入了多少个sheep 
            for(int i = 0; i < m; i++){
                cin>>str;
                if(str == "sheep") count++;
            }
            cout<<"Case"<<c++<<":This list contains "<<count<<" sheep."<<endl;
        }
        return 0;
    }
  • 相关阅读:
    pycharm快捷键
    Docker
    Go语言与Elasticsearch
    Celery与APScheduler
    爬虫入门到入狱
    数据分析
    后台管理
    Linux基础与自动化运维
    微信小程序
    Git
  • 原文地址:https://www.cnblogs.com/zhaoyulong/p/Dragon_Yu.html
Copyright © 2020-2023  润新知