• hide handkerchief



    Problem Description
    The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
    Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
    Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
    So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".
     

    Input
    There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.
     

    Output
    For each input case, you should only the result that Haha can find the handkerchief or not.
     

    Sample Input
    3 2
    -1 -1
     

    Sample Output
    YES
     

    当从m开始找时,如果m与n有公约数时,在找盒子时,就只会在这些约数的倍数之间找,而不是约数倍数的盒子就永远也不会被找到,所以当m与n的最大公约数为1,即m与n互质时才能找遍所有的盒子。

    (一)

    #include<stdio.h>
    #include<math.h>
    int Zhisu(int a,int b)
    {
        if((a-b)==0)
            return b;
        else
            Zhisu(b,abs(a-b));
    }
    void main()
    {
        int a,b;
        scanf("%d %d",&a,&b);
        while(a!=-1 && b!=-1)
        {
            if(Zhisu(a,b)==1)
                printf("YES ");
            else
                printf("POOR Haha ");
            scanf("%d %d",&a,&b);
        }
    }

    (二)

    #include<stdio.h>
    void main()
    {
        int a,b,c;
        while(1)
        {
            scanf("%d %d",&a,&b);
            if(a==-1 && b==-1)
                return;
            while(b!=0)
            {
                c=a%b;
                a=b;
                b=c;
            }
            if(a==1)
                printf("YES ");
            else
                printf("POOR Haha ");
        }
    }

  • 相关阅读:
    带有“全选”的combotree
    combotree(组合树)的使用
    根据权限显示accordion
    accordion(折叠面板)的使用
    js中substr、substring、indexOf、lastIndexOf的用法
    EasyUI中使用自定义的icon图标
    EasyUI tree的三种选中状态
    C# List集合去重使用lambda表达式
    C# DataTable去重,根据列名去重保留其他列
    win10下部署.Net Web项目到IIS10
  • 原文地址:https://www.cnblogs.com/zhaoxinshanwei/p/3499357.html
Copyright © 2020-2023  润新知