• hdu 2995 Robberies


    Problem Description
    The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


    For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


    His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
     

    Input
    The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
    Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
     

    Output
    For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

    Notes and Constraints
    0 < T <= 100
    0.0 <= P <= 1.0
    0 < N <= 100
    0 < Mj <= 100
    0.0 <= Pj <= 1.0
    A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
     

    Sample Input
    3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
     

    Sample Output
    2 4 6



    #include <iostream>
    #include <cstring>
    #include <algorithm>
    
    using namespace std;
    
    struct Bank
    {
        int money;  //现金数量
        float p;    //被抓概率
    } bank[105];
    
    int main()
    {
        int T;
        //用dp[i]表示偷价值为 i 时不被抓的概率,则状态转移方程为:
        //dp[j] = max(dp[j] , dp[j-money[i]] * (1-p[i]));
        float dp[10005];
        cin>>T;
        while(T--)
        {
            float P;  //被抓概率的限度
            int N;    //银行的数目
            cin>>P>>N;
    
            int sum=0;
            for(int i=0; i<N; i++)
            {
                cin>>bank[i].money>>bank[i].p;
                sum+=bank[i].money;
            }
    
            memset(dp,0,sizeof(dp));
            dp[0]=1;
    
            for(int i=0; i<N; i++)
            {
                for(int j=sum; j>=bank[i].money; j--)
                {
                    dp[j]=max(dp[j],dp[j-bank[i].money]*(1-bank[i].p));
                }
            }
    
            for(int i=sum; i>=0; i--)
            {
                if(dp[i]>1-P)
                {
                    cout<<i<<endl;
                    break;
                }
            }
    
    
        }
        return 0;
    }
    
    



  • 相关阅读:
    Write File in Vugen
    2016.5.15 随笔————查看class 的 Jad 反编译插件安装
    2016.5.15 随笔————Tomcat 配置文件 server.xml
    2016.5.10 随笔——Jmeter架入 java中使用 说明
    2016.5.10 随笔——SQL语句
    怎么和小孩一起玩--科学之旅:给孩子一场纯粹的玩耍(图)
    三味书屋 bbb
    亚信数据的组织结构
    深度学习的几个关键点
    数据可视化产品
  • 原文地址:https://www.cnblogs.com/zhanyeye/p/9746119.html
Copyright © 2020-2023  润新知