• nyoj 546 Divideing Jewels


    Divideing Jewels

    时间限制:1000 ms  |  内存限制:65535 KB

    难度:4

    描述

    Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same value, because then they could just split the collection in half. But unfortunately, some of the jewels are larger, or more beautiful than others. So, Mary and Rose start by assigning a value, a natural number between one and ten, to each jewel. Now they want to divide the jewels so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the jewels in this way (even if the total value of all jewels is even). For example, if there are one jewel of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the jewels.

    输入

    Each line in the input file describes one collection of jewels to be divided. The lines contain ten non-negative integers n1 , . . . , n10 , where ni is the number of jewels of value i. The maximum total number of jewells will be 10000. 
    The last line of the input file will be "0 0 0 0 0 0 0 0 0 0"; do not process this line. 

    输出

    For each collection, output "#k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
    Output a blank line after each test case. 

    样例输入

    1 0 1 2 0 0 0 0 2 0

    1 0 0 0 1 1 0 0 0 0

    0 0 0 0 0 0 0 0 0 0

    样例输出

    #1:Can't be divided.

     

    #2:Can be divided.

     

    #include<string.h>
    #include<stdio.h>
    int a[10];
    int f[120005];
    int v,k;
    void ZeroOnePack(int cost,int weight)
    {
    	for(int i=v;i>=cost;i--)
    		if(f[i]<f[i-cost]+weight)
    			f[i]=f[i-cost]+weight;
    }
    void ComplementPack(int cost,int weight)
    {
    	for(int i=cost;i<=v;i++)
    		if(f[i]<f[i-cost]+weight)
    			f[i]=f[i-cost]+weight;	
    }
    void MutiplePack(int cost ,int weight,int amount)
    {
    	if(cost*amount>=v)
    		ComplementPack(cost,weight);
    	else
    	{
    		for(int k=1;k<amount;k++)
    		{
    			ZeroOnePack(k*cost,k*weight);
    			amount-=k;
    			k=k*2;
    		}
    		ZeroOnePack(amount*cost,amount*weight);
    	}
    }
    int main()
    {
    	int tol;
    	int icase=0;
    	while(1)
    	{
    		icase++;
    		tol=0;
    		for(int i=1;i<=10;i++)
    		{
    			scanf("%d",&a[i]);
    			tol	+=a[i]*i;
    		}
    		if(tol==0)break;
    		if(tol%2==1)
    		{
    			printf("#%d:Can't be divided.
    
    ",icase);
    			continue;
    		}
    		else
    		{
    			v=tol/2;
    			memset(f,0,sizeof(f));
    			for(int i=1;i<=10;i++)
    				MutiplePack(i,i,a[i]);
    			if(f[v]==v)
    				printf("#%d:Can be divided.
    
    ",icase);
    			else
    				printf("#%d:Can't be divided.
    
    ",icase);
    		}
    			
    	}
    	return 0;
    }   
    

      

  • 相关阅读:
    lunix下的redis数据库操作——set集合
    lunix下的redis数据库操作——hash(哈希)
    lunix下的redis数据库操作——list列表
    python操作mysql
    linux修改mysql表结构
    关于wordclou的一些简单操作
    SQL NOW() 函数:返回当前系统的日期和时间
    SQL ROUND() 函数:把数值字段四舍五入为指定的小数位数
    SQL LEN() 函数:返回文本字段中值的长度
    SQL MID() 函数:从文本字段中提取字符
  • 原文地址:https://www.cnblogs.com/zhangliu/p/7053372.html
Copyright © 2020-2023  润新知