• nyoj 284


    坦克大战

    时间限制:1000 ms  |  内存限制:65535 KB

    难度:3

    描述

    Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 
    What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 

     


    Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

    输入

    The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

    输出

    For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

    样例输入

    3 4

    YBEB

    EERE

    SSTE

    0 0

    样例输出

    8

    #include <iostream>
    #include <queue>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    #define  max 301
    char map[max][max];//地图大小 
    int n,m;
    bool vist[max][max];
    int d[4][2]={{1,0},{0,1},{-1,0},{0,-1}};//四个方位 
    
    struct point 
    {
        int x,y,step;
        friend bool operator <(const point &s1,const point &s2)
        {
            return s1.step>s2.step;
        }
    };
    point s,e;
    
    int bfs()
    {
        priority_queue < point > q;//优先队列 
        memset(vist,0,sizeof(vist));
        point now,t;
        s.step=0;
        q.push(s);
        vist[s.x][s.y]=1;
        while (!q.empty())
        {
            now=q.top();
            q.pop();
            if (now.x==e.x&&now.y==e.y)//坦克就在目的地 
            {
                return now.step;
            }    
            for (int i=0;i<4;i++)
            {
                t.x=now.x+d[i][0];
                t.y=now.y+d[i][1];
                if (t.x>=0&&t.x<n&&t.y>=0&&t.y<m&&!vist[t.x][t.y])
                {        
                    vist[t.x][t.y]=1;    
                    if (map[t.x][t.y]=='B')
                    {
                        t.step=now.step+2;
                        q.push(t);
                    }
                    else 
                        if (map[t.x][t.y]=='E'||map[t.x][t.y]=='T')
                        {
                            t.step=now.step+1;
                            q.push(t);
                        }
                }
            }
        }
        return -1;
    }
    
    int main()
    {
        int i,j;
        while (cin>>n>>m,m+n)
        {
            for (i=0;i<n;i++)
            {
                for (j=0;j<m;j++)
                {
                    cin>>map[i][j];
                    if (map[i][j]=='Y')                  
                        s.x=i,s.y=j; //坦克位置                 
                    if (map[i][j]=='T')                  
                        e.x=i,e.y=j;//目的地                  
                }
            }
            int sum=bfs();
         cout<<sum<<endl;
        }
        
        return 0;
    }        
    

      

  • 相关阅读:
    Centos 6下使用cmake编译安装MariaDB
    mysql索引
    mysql基础指令知识
    git/github安装与使用教程
    Linux目录结构详解
    static关键字的作用(修饰类、方法、变量、静态块)
    Java中重载(overloading)和重写(Overriding)的区别
    @PropertySources和@ImportReSources注解
    @ConfigurationProperties注解和@Value注解的区别
    Java中数组的定义,初始化和使用
  • 原文地址:https://www.cnblogs.com/zhangliu/p/7052561.html
Copyright © 2020-2023  润新知