• Saruman's Army


    Description

    Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

    Input

    The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xnof each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

    Output

    For each test case, print a single integer indicating the minimum number of palantirs needed.

    Sample Input

    0 3
    10 20 20
    10 7
    70 30 1 7 15 20 50
    -1 -1

    Sample Output
    2
    4
    Hint

    In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

    In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

    题目大意:

    在给的数组中选出几个数,在这些数字的[x-r,x+r]区间要尽可能覆盖比较多的数组中的数,只有这样需要做标记的数字才可能最少

    import java.util.Arrays;
    import java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            Scanner scanner = new Scanner(System.in);
           while (true){
    
               int r = scanner.nextInt();
               int n = scanner.nextInt();
               if(r==-1&&n==-1){
                   break;
               }
               int []x = new int[n];
               for(int i=0;i<n;i++){
                   x[i] = scanner.nextInt();
               }
               int i = 0;
               int count = 0;
               Arrays.sort(x);
               int mark;
               while (i<n){
                   mark = x[i];
                   i++;
                   while (i<n&&x[i]<= mark+ r)
                       i++;
                    mark = x[i-1];
                   while (i<n&&x[i]<=mark+r)
                       i++;
                   count++;
               }
               System.out.println(count);
           }
        }
    }




  • 相关阅读:
    JDK6的switch支持不是很好
    团队作业(2)
    团队作业(1)
    4月30日
    重构:改善既有代码的设计有感
    4月28日
    4月27日
    4月26日
    4月25日
    4月24日
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/8433409.html
Copyright © 2020-2023  润新知