• 1084 Broken Keyboard (20 分)字符串


    1084 Broken Keyboard (20 分)

    On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

    Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

    Input Specification:

    Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

    Output Specification:

    For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

    Sample Input:

    7_This_is_a_test
    _hs_s_a_es
    

    Sample Output:

    7TI
    思路
      c++中对字符串进行整体大小写转换可以使用transform函数,对某个字符进行大小写转换,可以使用toupper()和tolower函数
    对vector进行查找,使用find函数,用法是find(vec.begin(),vec.end(),num_to_find)
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    #include<stack>
    using namespace std;
    vector<int> po;
    
    
    int main()
    {
        
        string str,temp;
        cin>>str>>temp;
        transform(str.begin(),str.end(),str.begin(),::toupper);
        transform(temp.begin(),temp.end(),temp.begin(),::toupper);
    
        vector<char> print;
       // print.find();
        int j=0;
        for(int i=0;i<str.size();i++)
        {
            //cout<<str[i]<<" "<<temp[j]<<endl;
            if(str[i]==temp[j])
                j++;
            else
                if(find(print.begin(),print.end(),str[i])==print.end())
                    print.push_back(str[i]);
        }
        for(auto it:print)
            cout<<it;
        return 0;
    }



  • 相关阅读:
    ORACLE常用SQL(session&badSql)
    归档日志满解决方法
    SPRING MVC总结
    Java中分割字符串
    无废话ExtJs 入门教程二十一[继承:Extend]
    无废话ExtJs 入门教程二十[数据交互:AJAX]
    WAMP 80端口被Microsoft-HTTPAPI/2.0占用的解决办法
    WampServer安装图解教程
    vmware tools安装程序无法继续,Microsoft Runtime DLL安装程序未能完成安装。的解决方法
    WordPress添加网站图标
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10314532.html
Copyright © 2020-2023  润新知