• 1120 Friend Numbers (20 分)set的使用


    1120 Friend Numbers (20 分)

    Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID's among them.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104​​.

    Output Specification:

    For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

    Sample Input:

    8
    123 899 51 998 27 33 36 12
    

    Sample Output:

    4
    3 6 9 26
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    using namespace std;
    
    
    
    int main()
    {
        int n;
        cin>>n;
        string str;
        set<int> num;
        for(int i=0;i<n;i++)
        {
            cin>>str;
            int sum=0;
            for(int j=0;j<str.size();j++)
            {
                sum+=str[j]-'0';
            }
            num.insert(sum);
        }
        cout<<num.size()<<endl;
        cout<<*(num.begin());
        //num.erase(*(num.begin()));
        for(auto t=++num.begin();t!=num.end();t++)
        {
            cout<<" "<<*t;
        }
        return 0;
    }

      
  • 相关阅读:
    windows7下检测耳机麦克拔插(转)
    windows实时监测热插拔设备的变化(转)
    Windows ToolTips简要介绍(转)
    c /c++变参函数(转)
    SQL的四种连接查询(转)
    CRichEditCtrl 输入字符串长度限制
    MFC 将 '当前工作路径' 改为 'exe所在路径'(转)
    第5章 文本编程
    第4章 简单绘图
    VC++中有关句柄和指针及其转换(转)
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10303584.html
Copyright © 2020-2023  润新知