• Codeforces233A Perfect Permutation


    Perfect Permutation
    Problem Description

    A permutation is a sequence of integersp1,p2,...,pn, consisting ofn distinct positive integers, each of them doesn't exceedn. Let's denote the i-th element of permutation p aspi. We'll call numbern the size of permutation p1,p2,...,pn.

    Nickolas adores permutations. He likes some permutations more than the others. He calls such permutations perfect. Aperfect permutation is such permutation p that for any i (1≤in) (n is the permutation size) the following equations holdppi=i andpii. Nickolas asks you to print any perfect permutation of sizen for the given n.

     

    Input

    A single line contains a single integer n (1≤n≤100) the permutation size.

     

    Output

    If a perfect permutation of size n doesn't exist, print a single integer -1. Otherwise print n distinct integers from 1 to n,p1,p2,...,pn permutationp, that is perfect. Separate printed numbers by whitespaces.

     

    Sample Input
    1
    2
     

    Sample Output
    -1
    2 1
     题目意思:
    给你一个n,则会有排列p1,p2,p3,p4...pn,并且pi<=n,;
    如果n的某个排列满足:ppi=i andpii.(1<=i<=n),则此排列为完美排列。
    输出这个排列。。

    可以找出规律,当n%2== 1 时,必定找不出符合条件的完美排列。。
    所以有:
    #include"stdio.h"
    int main()
    {
    	int n; 
        while(scanf("%d", &n) != EOF) 
        { 
            if(n % 2) 
            { 
                printf("-1\n"); 
            } 
            else 
            { 
                int i; 
                for(i = 1; i <= n; i++) 
                { 
                    if(i % 2) 
                    { 
                        printf("%d", i + 1); 
                    } 
                    else 
                        printf("%d", i - 1); 
                    if(i != n) 
                        printf(" "); 
                } 
                printf("\n"); 
            } 
    	}
    	return 0;
    }



  • 相关阅读:
    Python3标准库:copy复制对象
    Python3标准库:weakref对象的非永久引用
    Python3标准库:queue线程安全的FIFO实现
    Python3标准库:bisect维护有序列表
    Python3标准库:struct二进制数据结构
    Python3标准库:heapq堆排序算法
    Python3标准库:array数组
    Python3标准库:collections容器数据类型
    20-如何运行容器?
    19-Docker 镜像小结
  • 原文地址:https://www.cnblogs.com/yyf573462811/p/6365153.html
Copyright © 2020-2023  润新知