• hdu4861 Couple doubi---2014 Multi-University Training Contest 1


    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4861


    Couple doubi

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 238    Accepted Submission(s): 199


    Problem Description
    DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.
     

    Input
    Multiply Test Cases. 
    In the first line there are two Integers k and p(1<k,p<2^31).
     

    Output
    For each line, output an integer, as described above.
     

    Sample Input
    2 3 20 3
     

    Sample Output
    YES NO
     

    Author
    FZU
     

    Source
     

    Recommend
    We have carefully selected several similar problems for you:  4871 4869 4868 4867 4866 
     


    严格来讲,这应该是道数学题。但是假设是推导的话,数学沫沫表示死都推不出来。。。

    于是果断。打几个小数据找规律了。

    。。

    20 3
    0 2 0 2 0 2 0 2 0 2 0 2 0 2 0 2 0 2 0 2
    20 5
    0 0 0 4 0 0 0 4 0 0 0 4 0 0 0 4 0 0 0 4




    多试几个非常easy能够发现规律。。。仅仅有在p-1的倍数时有非0元素存在。

    那么因为是博弈,大家每次肯定都是选那个比較大的数,所以。若是 k/(p-1)为奇数则先手必胜。否则平局


    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cmath>
    #include<cstring>
    #include<cstdlib>
    #include<vector>
    #include<set>
    #include<map>
    #include<bitset>
    using namespace std;
    int main(){
        int k,p;
        while(cin>>k>>p){
            if(k/(p-1)&1) cout<<"YES"<<endl;
            else cout<<"NO"<<endl;
        }
        return 0;
    }
    






  • 相关阅读:
    null和undefined的区别
    【面试】前端面试题总结一(css)
    【js基础类】火狐的滚动事件
    【Vue】provide和inject
    React学习:react-router-dom-主要组件
    React学习:组合VS继承
    React学习:状态提升
    React学习:form表单
    unity+ARKit 捕捉表情录制动画 表情动画与人形骨骼动画融合
    Unity导入模型材质球无法编辑属性解决方法
  • 原文地址:https://www.cnblogs.com/yxysuanfa/p/7094743.html
Copyright © 2020-2023  润新知