• poj 1028 Web Navigation(模拟)


    题目链接:http://poj.org/problem?

    id=1028


    Description

    Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this. 
    The following commands need to be supported: 
    BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored. 
    FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored. 
    VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied. 
    QUIT: Quit the browser. 
    Assume that the browser initially loads the web page at the URL http://www.acm.org/

    Input

    Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

    Output

    For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

    Sample Input

    VISIT http://acm.ashland.edu/
    VISIT http://acm.baylor.edu/acmicpc/
    BACK
    BACK
    BACK
    FORWARD
    VISIT http://www.ibm.com/
    BACK
    BACK
    FORWARD
    FORWARD
    FORWARD
    QUIT

    Sample Output

    http://acm.ashland.edu/
    http://acm.baylor.edu/acmicpc/
    http://acm.ashland.edu/
    http://www.acm.org/
    Ignored
    http://acm.ashland.edu/
    http://www.ibm.com/
    http://acm.ashland.edu/
    http://www.acm.org/
    http://acm.ashland.edu/
    http://www.ibm.com/
    Ignored

    Source


    题意:

    模拟浏览器浏览网页是前后翻页。

    思路:

    开两个栈。分别存储当前网页前后的网页,注意新訪问一个网页时,应该把当前网页的前面的栈清空!

    代码例如以下:

    #include <iostream>
    #include <algorithm>
    #include <string>
    #include <stack>
    using namespace std;
    stack <string>b;
    stack <string>f;
    int main()
    {
        string tt = "http://www.acm.org/";
        string s;
        while(cin >> s)
        {
            if(s == "QUIT")
                break;
            if(s == "VISIT")
            {
                b.push(tt);
                cin >> tt;
                cout<<tt<<endl;//始终输出当前页
                while(!f.empty())//当新訪问一个页面的时候把之前页面前面的清空
                {
                    f.pop();
                }
            }
            else if(s == "BACK")
            {
                if(!b.empty())
                {
                    f.push(tt);
                    tt = b.top();
                    b.pop();
                    cout<<tt<<endl;//始终输出当前页
                }
                else
                    cout<<"Ignored"<<endl;
            }
            else
            {
                if(!f.empty())
                {
                    b.push(tt);
                    tt = f.top();
                    f.pop();
                    cout<<tt<<endl;//始终输出当前页
                }
                else
                    cout<<"Ignored"<<endl;
            }
        }
        return 0;
    }


  • 相关阅读:
    Java 借助poi操作PDF工具类
    【ES】Java High Level REST Client 使用示例(增加修改)
    数据库表结构查询SQL
    MySQL windows中的存储备份
    jenkins + Ansible Plugin + ansi-color 让结果显示颜色
    jenkins 构建历史 显示版本号
    python 2.7.11 环境安装
    ansible 安装和使用
    豌豆夹Redis解决方案Codis安装使用
    Spark on Mesos部署
  • 原文地址:https://www.cnblogs.com/yxwkf/p/5394222.html
Copyright © 2020-2023  润新知