• 1019 General Palindromic Number (20)(20 point(s))


    problem

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
    
    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits a~i~ as the sum of (a~i~b^i^) for i from 0 to k. Here, as usual, 0 <= a~i~ < b for all i and a~k~ is non-zero. Then N is palindromic if and only if a~i~ = a~k-i~ for all i. Zero is written 0 in any base and is also palindromic by definition.
    
    Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
    
    Input Specification:
    
    Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 10^9^ is the decimal number and 2 <= b <= 10^9^ is the base. The numbers are separated by a space.
    
    Output Specification:
    
    For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "a~k~ a~k-1~ ... a~0~". Notice that there must be no extra space at the end of output.
    
    Sample Input 1:
    
    27 2
    Sample Output 1:
    
    Yes
    1 1 0 1 1
    Sample Input 2:
    
    121 5
    Sample Output 2:
    
    No
    4 4 1
    

    tip

    answer

    #include<iostream>
    #include<string>
    #include<vector>
    
    #define LL long long 
     
    using namespace std;
    LL N, b;
    vector<LL> s;
    
    int main(){
    //	freopen("test.txt", "r", stdin);
    	ios::sync_with_stdio(false);
    	cin>>N>>b;
    	LL t = N;
    	while(t > 0){
    		s.push_back(t%b);
    		t /= b;
    	}
    	bool flag = true;
    	size_t size = s.size();
    	for(int i = 0; i < size/2; i++){
    		if(s[i] != s[size-i-1]){
    			flag = false;
    			break;
    		}
    	}
    	if(flag) cout<<"Yes"<<endl;
    	else cout<<"No"<<endl;
    	if(N == 0) {
    		cout<<"0";
    		return 0;
    	}
    	for(int i = size-1; i >= 0; i--){
    		if(i == 0) {
    			cout<<s[i];
    			continue;
    		}
    		cout<<s[i]<<" ";
    	}
    	return 0;
    }
    

    exprience

    • 进制转换时的通用问题,注意n为0时的情况,单独考虑。
  • 相关阅读:
    python爬取网络上图片【小例子】
    python统计英文单词出现次数【小例子】
    python敏感字处理【小例子】
    platform操作系统信息
    迭代器
    xxxxx
    test
    Jquery
    Jquery二
    DOM文档对象模型
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/9320495.html
Copyright © 2020-2023  润新知