• Coins(多重背包)


    Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

    You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

    InputThe input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.OutputFor each test case output the answer on a single line.Sample Input

    3 10
    1 2 4 2 1 1
    2 5
    1 4 2 1
    0 0

    Sample Output

    8
    4
    #include<iostream>
    #include<cstring>
    using namespace std;
    const int maxn=100010;
    int dp[maxn];
    int main()
    {
        int n,m;
        int a[maxn],b[maxn];
        int sum[maxn];//每个硬币出现次数
        while(cin>>n>>m&&n&&m)
        {
            memset(dp,0,sizeof(dp));
            for(int i=0;i<n;i++)
               cin>>a[i];
            for(int i=0;i<n;i++)
               cin>>b[i];
            dp[0]=1;
            int ans=0;
            for(int i=0;i<n;i++)
            {
                memset(sum,0,sizeof(sum));
                for(int j=a[i];j<=m;j++)
                {
                    if(!dp[j]&&dp[j-a[i]]&&sum[j-a[i]]<b[i])
                    {
                        dp[j]=1;
                        sum[j]=sum[j-a[i]]+1;
                        ans++;
                    }
                }
            }
            cout<<ans<<endl;
        } 
        return 0;
    }
  • 相关阅读:
    EntityFramework Code-First 简易教程(五)-------领域类配置
    EntityFramework Code-First 简易教程(四)-------继承策略
    Springboot整合mybatis:Invalid bound statement (not found)
    centos7服务器安装mysql8
    redis-Jedis
    redis学习-集群模式cluster
    redis学习-发布订阅
    redis学习-持久化机制
    redis学习-简单事务
    redis学习-哨兵模式
  • 原文地址:https://www.cnblogs.com/ylrwj/p/11945416.html
Copyright © 2020-2023  润新知