• Codeforces Round #339 (Div. 2) A


    Description

    Programmer Rostislav got seriously interested in the Link/Cut Tree data structure, which is based on Splay trees. Specifically, he is now studying the expose procedure.

    Unfortunately, Rostislav is unable to understand the definition of this procedure, so he decided to ask programmer Serezha to help him. Serezha agreed to help if Rostislav solves a simple task (and if he doesn't, then why would he need Splay trees anyway?)

    Given integers l, r and k, you need to print all powers of number k within range from l to r inclusive. However, Rostislav doesn't want to spent time doing this, as he got interested in playing a network game called Agar with Gleb. Help him!

    Input

    The first line of the input contains three space-separated integers l, r and k (1 ≤ l ≤ r ≤ 1018, 2 ≤ k ≤ 109).

    Output

    Print all powers of number k, that lie within range from l to r in the increasing order. If there are no such numbers, print "-1" (without the quotes).

    Sample Input

    1 10 2

    2  4  5

    Sample Output

    1 2 4 8

    -1

    此题非常要注意什么时候循环结束,否则可能会爆long long

    #include<stdio.h>
    //#include<bits/stdc++.h>
    #include<string.h>
    #include<iostream>
    #include<math.h>
    #include<sstream>
    #include<set>
    #include<queue>
    #include<vector>
    #include<algorithm>
    #include<limits.h>
    #define inf 0x3fffffff
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    #define LL long long
    using namespace std;
    LL powll(LL x, LL n)
    {
        LL pw = 1;
        while (n > 0)
        {
            if (n & 1)      
                pw *= x;
            x *= x;
            n >>= 1;      
        }
        return pw;
    }
    int main()
    {
       LL l,r,k;
       LL x;
       cin>>l>>r>>k;
       int flag=0;
       for(int i=0;i<=66;i++)
       {
           if(x>r/k) break;
           x=powll(k,i);
           if(x>=l&&x<=r)
           {
               flag=1;
               cout<<x<<" ";
           }
       }
       if(flag==0)
       {
           puts("-1");
       }
       return 0;
    }
    

      

  • 相关阅读:
    计算机三级数据库-指导
    spring导入约束
    hibernater获取session时org.hibernate.service.spi.ServiceException错误
    springxml配置注入报错
    右键复制类的完整路径
    关于实体里的toString方法
    idea创建web项目环境
    框架快速找类
    如何在scdn博客里搜索自己博客文章
    永久消除自动产生的QQPCMgr
  • 原文地址:https://www.cnblogs.com/yinghualuowu/p/5134584.html
Copyright © 2020-2023  润新知