• HDU 1078 FatMouse and Cheese(记忆化搜索)


    传送门:

    http://acm.hdu.edu.cn/showproblem.php?pid=1078

    FatMouse and Cheese

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 13356    Accepted Submission(s): 5598


    Problem Description
    FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

    FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

    Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
     
    Input
    There are several test cases. Each test case consists of

    a line containing two integers between 1 and 100: n and k
    n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
    The input ends with a pair of -1's.
     
    Output
    For each test case output in a line the single integer giving the number of blocks of cheese collected.
     
    Sample Input
    3 1 1 2 5 10 11 6 12 12 7 -1 -1
     
    Sample Output
    37
     
    Source
     
    题目意思:
    老鼠初始时在nXn的矩阵的(0.0),每次最多向一个方向移动k格,每次移动过去的那个格子里面的数值必须比当前所在格子里面的大,求出路径上所有数值总和最大值
    分析:
    记忆化搜索
    就是搜的时候搜过的存起来,下次就不用搜了
    解析全在代码:
    code:
    #include<bits/stdc++.h>
    using namespace std;
    #define max_v 105
    int a[max_v][max_v];
    int dp[max_v][max_v];
    int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};//方向数组
    int n,k,ans;
    int dfs(int x,int y)
    {
        if(dp[x][y]!=0)//已经搜过的直接返回 记忆化搜索核心
            return dp[x][y];
        int xx,yy;
        int sum=0;
        for(int i=1;i<=k;i++)//k步
        {
            for(int j=0;j<4;j++)//四个方向
            {
                xx=x+dir[j][0]*i;
                yy=y+dir[j][1]*i;//下一个到达的点的坐标
                if(xx<=0||xx>n||yy<=0||yy>n)//越界
                    continue;
                if(a[xx][yy]>a[x][y])//要求下一个点奶酪大于本点
                    sum=max(sum,dfs(xx,yy));//找max
            }
            dp[x][y]=a[x][y]+sum;//能找到的最大值加上当前点的奶酪等于从x,y出发最多能吃到的奶酪值
        }
        return dp[x][y];
    }
    int main()
    {
        while(cin>>n>>k)
        {
            if(n==-1&&k==-1)
                break;
            memset(a,0,sizeof(a));
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    cin>>a[i][j];
                }
            }
            memset(dp,0,sizeof(dp));//初始化,记忆化搜索核心 判断这点有没有搜过
            ans=dfs(1,1);//从1,1出发开始搜
            cout<<ans<<endl;
        }
        return 0;
    }
     
  • 相关阅读:
    C语言开发CGI程序的简单例子
    js收集错误信息,错误上报
    php安装pear、pecl
    (转)进程与线程的一个简单解释
    php curl 中的gzip压缩性能测试
    (转载):() { :|:& }; : # <-- 打开终端,输入这个,回车.你看到了什么??
    (转)open和fopen的区别:
    C语言中typedef
    secureCRT使用VIM 像LINUX中那样对语法高亮
    iframe与主框架跨域相互访问方法
  • 原文地址:https://www.cnblogs.com/yinbiao/p/9348040.html
Copyright © 2020-2023  润新知