• Oil Deposit


    题目描述:

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

    输入:

    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

    输出:

    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

    样例输入:
    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0
    
    样例输出:
    0
    1
    2
    2
    
    #include<iostream>
    #include<stdio.h>
    #include<queue>
    using namespace std;
    char maze[101][101];
    bool mark[101][101];
    int go[8][2]={
    1,0,
    -1,0,
    0,1,
    0,-1,
    -1,-1,
    1,1,
    -1,1,
    1,-1
    };
    int m,n;
    void dfs(int x,int y){
        for (int i=0;i<8;i++){
            int nx=x+go[i][0];
            int ny=y+go[i][1];
            if (nx<0||nx>=m||ny<0||ny>=n) continue;
            if (maze[nx][ny]=='*' || mark[nx][ny]==true) continue;
            mark[nx][ny]=true;
            dfs(nx,ny);
        }
        return;
    }
    
    int main (){
        
        while (cin>>m>>n && !(m==0&&n==0)){
            for (int i=0;i<m;i++){
                //getchar(); 
                for (int j=0;j<n;j++){
                    //scanf("%c",maze[i][j]);
                    cin>>maze[i][j];
                    mark[i][j]=false;
                }
            }
    
            int ans=0;
            for (int i=0;i<m;i++){
                for (int j=0;j<n;j++){
                    if (maze[i][j]=='*') continue;
                    if (mark[i][j]==true) continue;
                    dfs(i,j);
                    ans++;
                }
            }
            cout<<ans<<endl;
        }
    
        return 0;
    }

     这种将相邻的点合成块的算法有一个专有名词,floodfill

  • 相关阅读:
    [USACO09Open] Tower of Hay 干草塔
    [HNOI2004]打鼹鼠
    BZOJ1222[HNOI 2001]产品加工
    BZOJ1270[BJWC2008]雷涛的小猫
    NOIP2018出征策
    解析·NOIP·冷门 CLZ最小环
    CCF-NOIP-2018 提高组(复赛) 模拟试题(九)(2018 CSYZ长沙一中)
    [脚本无敌1]图片批量处理(matlab)
    用Matlab解《2013年数据建模比赛》图像碎片拼接题
    火灾检测-fire,fire
  • 原文地址:https://www.cnblogs.com/yexiaoqi/p/7241302.html
Copyright © 2020-2023  润新知