• hdu-Fibonacci


    Problem Description
    2007年到来了。经过2006年一年的修炼,数学神童zouyu终于把0到100000000的Fibonacci数列
    (f[0]=0,f[1]=1;f[i] = f[i-1]+f[i-2](i>=2))的值全部给背了下来。
    接下来,CodeStar决定要考考他,于是每问他一个数字,他就要把答案说出来,不过有的数字太长了。所以规定超过4位的只要说出前4位就可以了,可是CodeStar自己又记不住。于是他决定编写一个程序来测验zouyu说的是否正确。
     
    Input
    输入若干数字n(0 <= n <= 100000000),每个数字一行。读到文件尾。
     
    Output
    输出f[n]的前4个数字(若不足4个数字,就全部输出)。
     
    Sample Input
    0 1 2 3 4 5 35 36 37 38 39 40
     
    Sample Output
    0 1 1 2 3 5 9227 1493 2415 3908 6324 1023
      log10(an)=-0.5*log10(5.0)+((double)n)*log(f)/log(10.0)+log10(1-((1-√5)/(1+√5))^n)其中f=(sqrt(5.0)+1.0)/2.0;
    log10(1-((1-√5)/(1+√5))^n)->0
    所以可以写成log10(an)=-0.5*log10(5.0)+((double)n)*log(f)/log(10.0);
    最后取其小数部分。
    ————————————————

    代码:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <map>
    #include <vector> 
    #include <cmath>
    using namespace std;
    int main()  
    {  
        int f[22]={0,1,1};  
        for (int i = 3 ; i <= 20 ; i++)  
            f[i] = f[i-1] + f[i-2];  
        double n;  
        double a1 = log10(1.0 / sqrt(5));  
        double a2 = log10((1 + sqrt(5)) / 2);  
        while (cin>>n)  
        {  
            if (n <= 20)  
            {  
                cout<<f[(int)n]<<endl;  
                continue;  
            }  
            double ans = a1 + n * a2;  
            ans -= floor(ans);  
            ans = pow (10,ans);  
            ans = (int)(ans * 1000);  
            cout<<ans<<endl;  
        }  
        return 0;  
    }
    
     
  • 相关阅读:
    异常机制和File类
    《JAVA程序设计》_第五周学习总结
    20165214 第五周学习任务
    20165214 第四周学习任务
    20165214 第三周学习任务
    20165214 预备作业3 Linux安装及学习
    20165313 预备作业3 Linux安装及学习
    学习基础和C语言基础调查
    20165313 我期望的师生关系
    int *ptr=(int *)(&a+1)
  • 原文地址:https://www.cnblogs.com/yelir/p/11588693.html
Copyright © 2020-2023  润新知