• HDU 5344(MZL's xor-(ai+aj)的异或和)


    MZL's xor

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 800    Accepted Submission(s): 518


    Problem Description
    MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1i,jn)
    The xor of an array B is defined as B1 xor B2...xor Bn
     

    Input
    Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
    Each test case contains four integers:n,m,z,l
    A1=0,Ai=(Ai1m+z) mod l
    1m,z,l5105,n=5105
     

    Output
    For every test.print the answer.
     

    Sample Input
    2 3 5 5 7 6 8 8 9
     

    Sample Output
    14 16
     

    Author
    SXYZ
     

    Source
     

    Recommend
    wange2014   |   We have carefully selected several similar problems for you:  5416 5415 5414 5413 5412 
     



    (Ai+Aj)^(Aj+Ai)=0 (i≠j)

    然后注意开long long 否则 ai*m时会爆




    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<algorithm>
    #include<functional>
    #include<iostream>
    #include<cmath>
    #include<cctype>
    #include<ctime>
    using namespace std;
    #define For(i,n) for(int i=1;i<=n;i++)
    #define Fork(i,k,n) for(int i=k;i<=n;i++)
    #define Rep(i,n) for(int i=0;i<n;i++)
    #define ForD(i,n) for(int i=n;i;i--)
    #define RepD(i,n) for(int i=n;i>=0;i--)
    #define Forp(x) for(int p=pre[x];p;p=next[p])
    #define Forpiter(x) for(int &p=iter[x];p;p=next[p])  
    #define Lson (x<<1)
    #define Rson ((x<<1)+1)
    #define MEM(a) memset(a,0,sizeof(a));
    #define MEMI(a) memset(a,127,sizeof(a));
    #define MEMi(a) memset(a,128,sizeof(a));
    #define INF (2139062143)
    #define F (100000007)
    #define MAXN (5000000+10)
    typedef long long ll;
    ll mul(ll a,ll b){return (a*b)%F;}
    ll add(ll a,ll b){return (a+b)%F;}
    ll sub(ll a,ll b){return (a-b+llabs(a-b)/F*F+F)%F;}
    void upd(ll &a,ll b){a=(a%F+b%F)%F;}
    ll a[MAXN];
    ll n,m,z,l;
    int main()
    {
    //	freopen("B.in","r",stdin);
    	int T;cin>>T;
    	while(T--) 
    	{
    		cin>>n>>m>>z>>l;
    		a[1]=0;
    		Fork(i,2,n) a[i]=(a[i-1]*m+z)%l;
    		ll s=0;
    		For(i,n) s=s^(2*a[i]);
    		cout<<s<<endl;
    	} 
    	
    	
    	return 0;
    }
    





  • 相关阅读:
    利用python脚本统计和删除redis key
    利用expect交互完成多台linux主机ssh key推送
    iptables -L很慢的原因
    tomcat各个端口的作用
    rabbitmq集群搭建
    ping 没有回icmp reply
    go mod 无法下载依赖问题
    0/1 nodes are available: 1 node(s) had taint
    go 编译:build constraints exclude all Go files in
    k8s单机部署
  • 原文地址:https://www.cnblogs.com/yangykaifa/p/7026274.html
Copyright © 2020-2023  润新知