• poj1847 Tram(最短路dijkstra)


    描述:

    Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

    When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

    Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.
    Input
    The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

    Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.
    Output
    The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".
    Sample Input
    3 2 1
    2 2 3
    2 3 1
    2 1 2
    
    Sample Output
        0
     
     

    题意:

      有n个点,并且给了起点和终点ab,接下来的n行的第一个数k表示与第i个点相连的点数,每一行接下来有k个数,表示与i点相连接的点,并且在这k个点中,第一个点可直接到达,及路径长度为0,其他的点需要改一次扳手,路径长度为1,用dijkstra即可解决。

    代码:

    #include <iostream>
    #include <stdio.h>
    
    using namespace std;
    #define inf 100100100
    bool vis[105];
    int n,a,b;
    int map[105][105];
    int d[105];
    
    void dijkstra()
    {
        int i,j,v,f;
        for(i=1;i<=n;i++)
        {
            vis[i]=0;
            d[i]=map[a][i];
        }
        vis[a]=1;
        d[a]=0;
        for(i=1;i<n;i++)
        {
            f=inf;v=a;
            for(j=1;j<=n;j++)
            {
                if(d[j]<inf&&!vis[j]&&d[j]<f)
                {
                    f=d[j];
                    v=j;
                }
            }
            if(f>inf) break;
            vis[v]=1;
            for(j=1;j<=n;j++)
                if(!vis[j]&&map[v][j]<inf&&d[v]+map[v][j]<d[j])
                    d[j]=d[v]+map[v][j];
        }
    }
    
    int main()
    {
        int k,m;
        scanf("%d%d%d",&n,&a,&b);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                if(i==j) map[i][j]=0;
                else map[i][j]=inf;
            }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&k);
            for(int j=0;j<k;j++)
            {
                scanf("%d",&m);
                if(j==0) map[i][m]=0;
                else map[i][m]=1;
            }
        }
        dijkstra();
        if(d[b]>=inf) cout<<"-1"<<endl;
        else
            cout<<d[b]<<endl;
        return 0;
    }
     
  • 相关阅读:
    Linux下安装Blender
    自我复制的3D打印机
    ODOO v10.0 自动生成财务凭证的科目设置
    初识Odoo的辅助核算
    Odoo9以后的社区版本和企业版功能上的区别
    06: linux中find查找命令总结
    02: shell中的if、case、for等语句
    01: shell基本使用
    05: 配置yum源
    04: linux基础总结-centos6.5
  • 原文地址:https://www.cnblogs.com/y1040511302/p/10474107.html
Copyright © 2020-2023  润新知