• [HDOJ]_PID_1004_Let the Balloon Rise


    题目:

    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
    
    This year, they decide to leave this lovely job to you.
    
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
    
    A test case with N = 0 terminates the input and this test case is not to be processed.
    
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
    
    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
    
    Sample Output
    red
    pink
    
    Author
    WU, Jiazhi
    
    Source
    ZJCPC2004
    
    Recommend
    JGShining

    代码:

    #include <iostream>
    #include <string>
    #include <map>
    #include <utility>
    
    using namespace std;
    
    int main(void) {
        int N;
    
        while (cin >> N && N != 0) {
            string word, result;
            map<string, int> word_count;
            pair<string, int> maxtimes;
            while (N-- && cin >> word) {
                ++word_count[word];
            }
    
            for (map<string, int>::const_iterator map_iter = word_count.begin();
                map_iter != word_count.end();
                ++map_iter) {
                if (map_iter->second > maxtimes.second) {
                    maxtimes.first = map_iter->first;
                    maxtimes.second = map_iter->second;
                }
            }
            cout << maxtimes.first << endl;
        }
        return 0;
    }
  • 相关阅读:
    qt学习笔记(1):qt点击运行没有反应。
    JS Object类型
    JS Boolean数据类型和数据类型转换规律
    CSS雪碧图
    CSS
    PS基础
    JS number数字类型
    js中的变量和数据类型
    JS 基础
    单词
  • 原文地址:https://www.cnblogs.com/xwoder/p/4596472.html
Copyright © 2020-2023  润新知