• 快速切题 poj3414 Pots


    Pots
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 10042   Accepted: 4221   Special Judge

    Description

    You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

    1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
    2. DROP(i)      empty the pot i to the drain;
    3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

    Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

    Input

    On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

    Output

    The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

    Sample Input

    3 5 4

    Sample Output

    6
    FILL(2)
    POUR(2,1)
    DROP(1)
    POUR(2,1)
    FILL(2)
    POUR(2,1)

    应用时:10min
    实际用时:57min
    原因:六种操作都是不可逆转的.
    思路:时间非常充裕到不需要建反边,数据太小
    #include <cstdio>
    #include <cstring>
    #include <queue>
    using namespace std;
    const int maxn=101;
    int n,m;
    typedef unsigned long long ull;
    int A,B,C;
    int vis[maxn][maxn];
    int ans[maxn][maxn][maxn*maxn];
    struct node{
        int a,b;
        node (int  ta,int tb):a(ta),b(tb){}
    };
    void printop(int op){
        switch(op){
        case 0:
            puts("FILL(1)");
            break;
        case 1:
            puts("FILL(2)");
            break;
        case 2:
            puts("POUR(1,2)");
            break;
        case 3:
            puts("POUR(2,1)");
            break;
        case 4:
            puts("DROP(1)");
            break;
        case 5:
            puts("DROP(2)");
            break;
        }
    }
    void op(int &a,int &b,int op){
        switch(op){
        case 0:
            a=A;
            break;
        case 1:
            b=B;
            break;
        case 2:
            if(b+a<=B){
                b+=a;
                a=0;
            }
            else {
                a-=B-b;
                b=B;
            }
            break;
        case 3:
            if(b+a<=A){
                a+=b;
                b=0;
            }
            else {
                b-=A-a;
                a=A;
            }
            break;
        case 4:
            a=0;
            break;
        case 5:
            b=0;
            break;
        }
    }
    void bfs(){
        queue <node> que;
        que.push(node(0,0));
        vis[0][0]=0;
        while(!que.empty()){
            node tp=que.front();que.pop();
            int ta=tp.a;
            int tb=tp.b;
            if(tp.a==C||tp.b==C){
                printf("%d\n",vis[tp.a][tp.b]);
                for(int i=0;i<vis[ta][tb];i++){
                    int op=ans[ta][tb][i];
                    printop(op);
                }
                return ;
            }
            for(int i=0;i<6;i++){
                int ta=tp.a;
                int tb=tp.b;
                op(ta,tb,i);
                if(vis[ta][tb]==-1){
                    vis[ta][tb]=vis[tp.a][tp.b]+1;
                    for(int j=0;j<vis[tp.a][tp.b];j++){
                        ans[ta][tb][j]=ans[tp.a][tp.b][j];
                    }
                    ans[ta][tb][vis[tp.a][tp.b]]=i;
                    que.push(node(ta,tb));
                }
            }
        }
        puts("impossible");
    }
    int main(){
        scanf("%d%d%d",&A,&B,&C);
            memset(vis,-1,sizeof(vis));
            bfs();
        return 0;
    }
    

      

  • 相关阅读:
    python基本数据类型
    大学排名之数据库练习
    Python turtle学习笔记
    初学爬虫
    用python进行对乒乓球的比赛分析,并且将该程序进行封装
    新网页
    Python pandas
    十大经典排序算法
    C++的split()函数
    C++多态意义探究
  • 原文地址:https://www.cnblogs.com/xuesu/p/3992538.html
Copyright © 2020-2023  润新知