• hdu4006 优先队列


    A - 签到

    Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:65768KB     64bit IO Format:%I64d & %I64u

    Description

    Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
     

    Input

    There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.
     

    Output

    The output consists of one integer representing the largest number of islands that all lie on one line.
     

    Sample Input

    8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
     

    Sample Output

    1 2 3

    HintXiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
    题目大意:

    有n步操作,I代表往这一串数里面再加一个,Q则代表查询第k大的数是哪一个。

    思路分析:首先要明白第k大的数实际上就是有k-1个数比他大,另外数据范围很大,直接暴力肯定TLE,

    因此可以想到使用优先队列这种数据结构,构造最小堆,堆顶的元素刚好是第k大的数,因此当q.size()>k时

    直接pop(),避免爆内存。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    #include <queue>
    #include <stack>
    #include <vector>
    using namespace std;
    int main()
    {
        int n,k,m;
        char s[5];
        while(scanf("%d%d",&n,&k)!=EOF)
        {
            priority_queue<int,vector<int>,less<int> >Q;
            while(n--)
            {
                scanf("%s",s);
                 if(s[0]=='I')
                 {
                        scanf("%d",&m);
                        Q.push(m);
                        if(Q.size()>k) Q.pop();
                 }
                else
                {
                    printf("%d ",Q.top());
                }
            }
        }
        return 0;
    }

     

  • 相关阅读:
    【LeetCode】203. Remove Linked List Elements
    【Leetcode】237. Delete Node in a Linked List
    char * const * (*a) (int b)
    排序算法
    系统设计
    PHP生成随机单词
    通过建立ssh信任,启动其他客户机的服务
    定时监控服务,告警,并启动服务
    定时监控所有服务器的端口,如果挂起,发送报警邮件
    反射
  • 原文地址:https://www.cnblogs.com/xuejianye/p/5572679.html
Copyright © 2020-2023  润新知