• uva11292贪心基础题目


    C - 贪心 基础

    Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

    Submit Status

    Description

    Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem.

    The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geese population was out of control. The people of Loowater mostly kept clear of the geese. Occasionally, a goose would attack one of the people, and perhaps bite off a finger or two, but in general, the people tolerated the geese as a minor nuisance.

    One day, a freak mutation occurred, and one of the geese spawned a multi-headed fire-breathing dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp. Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon and save the kingdom.

    The knights explained: "To slay the dragon, we must chop off all its heads. Each knight can chop off one of the dragon's heads. The heads of the dragon are of different sizes. In order to chop off a head, a knight must be at least as tall as the diameter of the head. The knights' union demands that for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the knight's height."

    Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp!

    Input

    The input contains several test cases. The first line of each test case contains two integers between 1 and 20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in the kingdom. The next n lines each contain an integer, and give the diameters of the dragon's heads, in centimetres. The following m lines each contain an integer, and specify the heights of the knights of Loowater, also in centimetres.

    The last test case is followed by a line containing:

    0 0

    Output

    For each test case, output a line containing the minimum number of gold coins that the king needs to pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the line:

    Loowater is doomed!

    Sample Input

    2 3
    5
    4
    7
    8
    4
    2 1
    5
    5
    10
    0 0
    

    Sample Output

    11
    Loowater is doomed!
    
    题目大意:有一只邪恶的龙,勇士们要杀掉他必须要干掉他的所有头,每一个勇士可以砍掉一个直径小于他身高的头,
    然后可以得到他身高的金子数量,问怎样选择才能让国王付出最少的代价杀死这条龙。
    思路分析:分别对身高和头的直径排序,每一个头都让比它高一点的人杀死,这样可以保证付出最少的代价。
    代码:
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    #include <stack>
    #include <queue>
    using namespace std;
    const int maxn=20000+10;
    int a[maxn],b[maxn];
    int main()
    {
        int n,m,i,j;
        while(scanf("%d%d",&n,&m)&&(m||n))
        {
            int k=0;
            for(i=0;i<n;i++)
            scanf("%d",&a[i]);
            for(i=0;i<m;i++)
            scanf("%d",&b[i]);
            sort(a,a+n);
            sort(b,b+m);
            int t=0;
            for(i=0;i<n;i++)
            {
                for(j=k;j<m;j++)
                {
                   if(a[i]<=b[j])
                   {
                       t+=b[j];
                       k=j+1;
                       break;
                   }
                }
                if(j==m) break;
            }
            if(i<n) cout<<"Loowater is doomed!"<<endl;
            else cout<<t<<endl;
        }
        return 0;
    }
  • 相关阅读:
    override与new的区别
    预处理指令关键字
    索引器
    可选参数与命名参数
    sealed关键字
    获取变量默认值
    is和as
    throw和throw ex的区别
    位操作
    unsafe关键字
  • 原文地址:https://www.cnblogs.com/xuejianye/p/5433771.html
Copyright © 2020-2023  润新知