• hdoj1003--Max Sum


    Problem Description
    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     
    Sample Input
    2
    5 6 -1 5 4 -7
    7 0 6 -1 1 -6 7 -5
     
    Sample Output
    Case 1: 14 1 4
    Case 2: 7 1 6
    #include<iostream>
    #include<cstdio>
    using namespace std;
    
    void solve()
    {
        int T, i, max,sum,n,num,begin,end,t,con;
        while(cin>>T) {
            for(i = 1; i <= T; i++) {
                max = -1000000;
                sum = 0;
                n = con = 0;
                cin>>n;
                num = n;
                begin = end = 0;
                while(n--) {
                    cin>>t;
                    sum += t;
                    con++;
                    if(sum > max) {
                        begin = con;
                        max = sum;
                        end = num - n;
                    }
                    if(sum < 0) {
                        sum = 0;
                        con = 0;
                    }
                }
                cout<<"Case "<<i<<":"<<endl<<max<<" "<<end-begin+1<<" "<<end<<endl;  
                if(i != T) cout<<endl;  
            }
        }
    }
    
    int main()
    {     
        solve();
        return 0;
    }
  • 相关阅读:
    vue实战(3):底部导航显示、搭建各模块静态页面、添加登录页页面与路由
    vue实战(2):初始化项目、搭建底部导航路由
    hexo
    移动端自适应
    vue过场动画
    获取 TypeScript
    TypeScript 与 JavaScript 的区别
    api封装使用
    vue学习
    dom的增删改
  • 原文地址:https://www.cnblogs.com/xueda120/p/3573868.html
Copyright © 2020-2023  润新知