• 【ACM】hdu_1808_Halloween treats_201308132022


    Halloween treats

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 434    Accepted Submission(s): 134
    Special Judge


    Problem Description
    Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

    Your job is to help the children and present a solution.

     
    Input
    The input contains several test cases.
    The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

    The last test case is followed by two zeros.

     
    Output
    For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet, print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.
     
    Sample Input
    4 5 1 2 3 7 5 3 6 7 11 2 5 13 17 0 0
     
    Sample Output
    3 5 2 3 4
     
    Source
     
     

    #include <stdio.h>
    #include <string.h>

    int a[101000],b[101000];

    int main()
    {
        int n,c;
        while(scanf("%d %d",&c,&n),c||n)
        {
            int i,j,sum,begin,end;
            memset(b,0,sizeof(b));
            for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
            sum=0;
            for(i=1;i<=n;i++)
            {
                sum=(sum+a[i])%c;
                if(sum==0)
                {
                    begin=1;
                    end=i;
                    break;
                }
                else if(!(b[sum]))
                {
                    b[sum]=i;
                }
                else
                {
                    begin=b[sum]+1;
                    end=i;
                }
            }
            for(i=begin;i<=end;i++)
            {
                if(i<end)
                printf("%d ",i);
                else
                printf("%d ",i);
            }
        }
        return 0;
    }

    //组合数学之抽屉原理   相关题目 poj 2356

     
  • 相关阅读:
    database homework1
    数据库基础
    MySQL操作
    [BZOJ 1305][CQOI2009]dance跳舞(网络流+二分答案)
    [BZOJ 1834][ZJOI2010]network 网络扩容(费用流)
    [BZOJ 3931][CQOI2015]网络吞吐量(SPFA+网络流)
    [BZOJ 3576][Hnoi2014]江南乐(博弈论)
    [BZOJ 1086][SCOI2005]王室联邦(贪心?树分块)
    [BZOJ 4765]普通计算姬(分块+树状数组)
    [BZOJ 4802]欧拉函数(Pollard_rho+Miller_Rabin)
  • 原文地址:https://www.cnblogs.com/xl1027515989/p/3255978.html
Copyright © 2020-2023  润新知