• 【ACM】hdu_zs3_1008_Train Problem I_201308100835


    Train Problem I
    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 8   Accepted Submission(s) : 2
    Problem Description
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

    Sample Input
    3 123 3213 123 312

    Sample Output
    Yes.inininoutoutoutFINISHNo.FINISHHintHintFor the first Sample Input, we let train 1 get in, then train 2 and train 3.So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.Now we can let train 3 leave.But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.So we output "No.".

    Author
    Ignatius.L

    #include <stdio.h>
    #include <string.h>

    char str1[10];
    char str2[10];
    int a[10],b[10],stack[10];
    int main()
    {
        int n;
        while(scanf("%d",&n)!=EOF)
        {
         int i,j,top;
         memset(str1,0,sizeof(str1));
         memset(str2,0,sizeof(str2));
         memset(a,0,sizeof(a));
         memset(b,0,sizeof(b));
         memset(stack,0,sizeof(stack));
         scanf("%s%s",str1,str2);
         for(j=0,i=0;i<strlen(str1);i++)
         a[j++]=str1[i]-'0';
         for(j=0,i=0;i<strlen(str2);i++)
         b[j++]=str2[i]-'0';
         top=1;
         for(j=0,i=0;i<n;i++)
         {
          stack[top++]=a[i];
          while(j<n&&(b[j]==stack[top-1]))
          {
           --top;
           j++;
          }
         }
         if(top==1)
         {
          printf("Yes. ");
          for(j=0,i=0;i<n;i++)
             {
               stack[top++]=a[i];printf("in ");
               while(j<n&&(b[j]==stack[top-1]))
               {
                --top;
                j++;
                printf("out ");
               }
             }
             printf("FINISH ");
         }
         else
         printf("No. FINISH ");     
        }
        return 0;
    }

  • 相关阅读:
    oracle11g安装客户端检查先决条件失败
    WinForm textbox 只允许输入数字
    Oracle存储过程
    Oracle游标
    Oracle之PL/SQL流程控制
    Oracle 变量
    log4net 使用
    Python Matplotlib 画图显示中文问题
    Oracle 数据迁移到 SQL Server
    C结构体【转】
  • 原文地址:https://www.cnblogs.com/xl1027515989/p/3253879.html
Copyright © 2020-2023  润新知