• ACM 推桌子


    推桌子

    时间限制:1000 ms  |  内存限制:65535 KB
    难度:3
     
    描述
    The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

    The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

    For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.
     
    输入
    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
    Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
    line, the remaining test cases are listed in the same manner as above.
    输出
    The output should contain the minimum time in minutes to complete the moving, one per line.
    样例输入
    3 
    4 
    10 20 
    30 40 
    50 60 
    70 80 
    2 
    1 3 
    2 200 
    3 
    10 100 
    20 80 
    30 50
    样例输出
    10
    20
    30
    注意题目要将给出的数据重新编号为1,2,3,4,......
    还要注意s和t的大小
    #include <iostream>
    #include <vector>
    #include <algorithm>
    
    using namespace std;
    
    struct TableMove{
        int first;
        int last;
        bool visit;
        TableMove(int first_ = 0,int last_ = 0, bool visit_ = false):first(first_),last(last_),visit(visit_){}
        bool operator <(const TableMove& a) const{
            if(first!=a.first) return first < a.first;
            else return last < a.last;
        }
    };
    
    int main(){
        int T;
        cin >>  T;
        for(int icase = 0 ; icase < T; icase ++){
            int n;
            cin >> n;
            vector<TableMove> tableMove(n);
            for(int i = 0 ; i < n; ++ i){
                cin >> tableMove[i].first >> tableMove[i].last;
                tableMove[i].first = (tableMove[i].first+1)/2;
                tableMove[i].last = (tableMove[i].last+1)/2;
                if(tableMove[i].first > tableMove[i].last)
                    swap(tableMove[i].first,tableMove[i].last);
            }
            sort(tableMove.begin(),tableMove.end());
            int cnt = 0;
            for(int i = 0 ; i  < n ; ++ i){
                if(!tableMove[i].visit){
                    cnt++;
                    TableMove t = tableMove[i];
                    tableMove[i].visit = true;
                    for(int j = i +1; j < n ; ++ j){
                        if(!tableMove[j].visit&&tableMove[j].first > t.last){
                            t =tableMove[j];
                            tableMove[j].visit = true;
                        }
                    }
                }
            }
            cout<<cnt*10<<endl;
        }
    }
    
    
    
     
  • 相关阅读:
    《转》2013年那些深入人心的小故事
    sklearn学习2-----LogisticsRegression
    sklearn学习汇总
    sklearn学习1----sklearn.SVM.SVC
    树(5)-----判断两颗树一样或者一棵树是否是另外一颗的子树
    树(4)-----树的高度
    面试题1-----SVM和LR的异同
    算法19-----(位运算)找出数组中出现只出现一次的数
    树(3)-----栈(迭代)
    python中的全局变量、局部变量、实例变量
  • 原文地址:https://www.cnblogs.com/xiongqiangcs/p/3664600.html
Copyright © 2020-2023  润新知