• LA 3263 平面划分


    Little Joey invented a scrabble machine that he called Euler, after the great mathematician. In his primary school Joey heard about the nice story of how Euler started the study about graphs. The problem in that story was - let me remind you - to draw a graph on a paper without lifting your pen, and finally return to the original position. Euler proved that you could do this if and only if the (planar) graph you created has the following two properties: (1) The graph is connected; and (2) Every vertex in the graph has even degree.

    Joey's Euler machine works exactly like this. The device consists of a pencil touching the paper, and a control center issuing a sequence of instructions. The paper can be viewed as the infinite two-dimensional plane; that means you do not need to worry about if the pencil will ever go off the boundary.

    In the beginning, the Euler machine will issue an instruction of the form (X0, Y0) which moves the pencil to some starting position (X0, Y0). Each subsequent instruction is also of the form (X', Y'), which means to move the pencil from the previous position to the new position (X', Y'), thus draw a line segment on the paper. You can be sure that the new position is different from the previous position for each instruction. At last, the Euler machine will always issue an instruction that move the pencil back to the starting position(X0, Y0). In addition, the Euler machine will definitely not draw any lines that overlay other lines already drawn. However, the lines may intersect.

    After all the instructions are issued, there will be a nice picture on Joey's paper. You see, since the pencil is never lifted from the paper, the picture can be viewed as an Euler circuit.

    Your job is to count how many pieces (connected areas) are created on the paper by those lines drawn by Euler.

    Input 

    There are no more than 25 test cases. Ease case starts with a line containing an integer N$ ge$4, which is the number of instructions in the test case. The following N pairs of integers give the instructions and appear on a single line separated by single spaces. The first pair is the first instruction that gives the coordinates of the starting position. You may assume there are no more than 300 instructions in each test case, and all the integer coordinates are in the range (-300, 300). The input is terminated when N is 0.

    Output 

    For each test case there will be one output line in the format

    Case x: There are w pieces.,

    where x is the serial number starting from 1.

    Note: The figures below illustrate the two sample input cases.

    epsfbox{p3263.eps}

    Sample Input 

    5
    0 0 0 1 1 1 1 0 0 0 
    7 
    1 1 1 5 2 1 2 5 5 1 3 5 1 1 
    0
    

    Sample Output 

    Case 1: There are 2 pieces. 
    Case 2: There are 5 pieces.

    题目大意:n个端点的一笔画,第n个端点跟第一个端点重合,它是一条闭合的曲线,求它把平面划分成多少部分。
    分析:
    欧拉定理:设平面的顶点数、边数、面数分别为V、E、F,则V+F-E=2。
    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<cmath>
    using namespace std;
    
    struct Point
    {
        double x,y;
        Point(double x=0,double y=0):x(x),y(y) {}
    };
    
    typedef Point Vector;
    Vector operator +(Vector A,Vector B){return Vector(A.x+B.x,A.y+B.y);}
    Vector operator -(Vector A,Vector B){return Vector(A.x-B.x,A.y-B.y);}
    Vector operator *(Vector A,double p){return Vector(A.x*p,A.y*p);}
    Vector operator /(Vector A,double p){return Vector(A.x/p,A.y/p);}
    bool operator < (const Point &a,const Point &b)
    {
        return a.x<b.x||(a.x==b.x&&a.y<b.y);
    }
    const double eps=1e-10;
    
    int dcmp(double x)
    {
        if(fabs(x)<eps) return 0;
        else return x<0?-1:1;
    }
    
    bool operator == (const Point &a,const Point &b){
        return (dcmp(a.x-b.x)==0 && dcmp(a.y-b.y)==0);
    }
    
    double Dot(Vector A,Vector B){return A.x*B.x+A.y*B.y;}
    double Length(Vector A){return sqrt(Dot(A,A));}
    double Angle(Vector A,Vector B){return acos(Dot(A,B)/Length(A)/Length(B));}
    
    double Cross(Vector A,Vector B){ return A.x*B.y-A.y*B.x;}
    
    Vector Rotate(Vector A,double rad)
    {
        return Vector(A.x*cos(rad)-A.y*sin(rad),A.x*sin(rad)+A.y*cos(rad));
    }
    
    Point GetLineIntersection(Point P,Vector v,Point Q,Vector w)//两直线的交点
    {
        Vector u=P-Q;
        double t=Cross(w,u)/Cross(v,w);
        return P+v*t;
    }
    
    bool SegmentProperIntersection(Point a1,Point a2,Point b1,Point b2)//两线段规范相交
    {
        double c1=Cross(a2-a1,b1-a1),c2=Cross(a2-a1,b2-a1),
            c3=Cross(b2-b1,a1-b1),c4=Cross(b2-b1,a2-b1);
        return dcmp(c1)*dcmp(c2)<0 && dcmp(c3)*dcmp(c4)<0;
    }
    
    bool OnSegment(Point p,Point a1,Point a2)
    {
        return dcmp(Cross(a1-p,a2-p))==0 && dcmp(Dot(a1-p,a2-p))<0;
    }
    
    const int maxn=300+10;
    Point P[maxn],V[maxn*maxn];
    
    int main()
    {
        int n,icase=0,i,j,e,c;
        while(scanf("%d",&n)==1 && n)
        {
            icase++;
            for(i=0;i<n;i++)
            {
                scanf("%lf %lf",&P[i].x,&P[i].y);
                V[i]=P[i];
            }
            n--;
    //e为边数,c为顶点数
    e
    =c=n; for(i=0;i<n;i++)//找两两线段规范相交的 { for(j=i+1;j<n;j++) { if(SegmentProperIntersection(P[i],P[i+1],P[j],P[j+1]))//两线段规范相交 { V[c++]=GetLineIntersection(P[i],P[i+1]-P[i],P[j],P[j+1]-P[j]); } } } sort(V,V+c); c=unique(V,V+c)-V;//不重复的顶点数量 for(i=0;i<c;i++)//如果点在线段上则加一条边 { for(j=0;j<n;j++) { if(OnSegment(V[i],P[j],P[j+1])) e++; } } //欧拉定理:v+f-e=2.
    printf(
    "Case %d: There are %d pieces. ",icase,e+2-c); } return 0; }

  • 相关阅读:
    我是如何折腾.NET Resx资源文件的 当计算机中的资源已经足够多时,我们也要学会尽可能的借用
    当程序开发人员开始抛弃技术时,是否意味着噩梦的开始?抛弃了SQL Server 2000才发现客户的简单问题真的很难解决
    分享.NET ERP项目开发中应用到的重量级工具 选择合适的工具和资源,做项目效率高而且规范程度高
    Management Console ERP项目开发辅助工具 正确的方法+适当的工具使做项目的效率高而且问题少
    ERP系统管理员的工具箱 推荐几款优秀的数据比较同步工具 Data Compare and Sync tool
    亲自下载CSDN社区600万用户数据 设计两条编程题目考验你的.NET编程基础
    知识管理系统Data Solution研发日记之十六 保存服务器文档为本机PDF格式
    【转】好的学习方法
    iPhone开发学习笔记[7/50]在xcode里配置成功subversion
    iPhone开发学习笔记[4/50]表视图的使用
  • 原文地址:https://www.cnblogs.com/xiong-/p/3381409.html
Copyright © 2020-2023  润新知