• ACM求和


    Let us consider sets of positive integers less than or equal to n. Note that all elements of a set are different. Also note that the order of elements doesnt matter, that is, both {3, 5, 9} and {5, 9, 3} mean the same set. Specifying the number of set elements and their sum to be k and s, respectively, sets satisfying the conditions are limited. When n = 9, k = 3 and s = 23, {6, 8, 9} is the only such set. There may be more than one such set, in general, however. When n = 9, k = 3 and s = 22, both {5, 8, 9} and {6, 7, 9} are possible. You have to write a program that calculates the number of the sets that satisfy the given conditions.

    Input

    The input consists of multiple datasets. The number of datasets does not exceed 100. Each of the datasets has three integers n, k and s in one line, separated by a space. You may assume 1 ≤ n ≤ 20, 1 ≤ k ≤ 10 and 1 ≤ s ≤ 155. The end of the input is indicated by a line containing three zeros.

    Output

    The output for each dataset should be a line containing a single integer that gives the number of the sets that satisfy the conditions. No other characters should appear in the output. You can assume that the number of sets does not exceed 231 − 1.

    Sample Input

    9 3 23

    9 3 22

    10 3 28

    16 10 107

    20 8 102

    20 10 105

    20 10 155

    3 4 3

    4 2 11

    0 0 0

    Sample Output

    1

    2

    0

    20

    1542

    5448

    1

    0

    0

    解题思路:

    题目大意是给定三个数,第一个数n表示的是我们可以用的数是小于等于它n的正整数,第二个数k表示我们有k个数相加,第三个数s表示我们这k个数加起来的和,必须是s.并且要求我们的k个数都不相等。我们通过建立一个函数,它的第一个参数是我们可以用到的数n,第二个参数用来控制我们所要的k个数,只有当第二个参数等于我们所给出的k时,我们在判断我们得到的k个数之和是否等于所给出的s,只有在等于的条件下我们才使我们用来累计方案数的数++。其中当第二个参数是0时,我们就从1开始,其他情况下我们都从上上一次我们取得的数再加一开始,这样防止重复的结果出现,然后我们就不断的递归。

    程序代码:

    #include<iostream>
    using namespace std;
    int a[3];
    int A[22];
    int ans=0;
    void dfs(int n,int cur)
    {
        if(cur==a[1])
    	{
            int sum=0;
            for(int i=0;i<a[1];i++)
    		{
                sum+=A[i];
            }
            if(sum==a[2])
    			ans++;
        }
        int s=1;
        if(cur!=0)
    		s=A[cur-1]+1;
        for(int i=s;i<=n;i++)
    	{
            A[cur]=i;
            dfs(n,cur+1);
        }
    }
    int main()
    {
            while(cin>>a[0]>>a[1]>>a[2]&&a[0]+a[1]+a[2])
    		{
                ans=0;
                dfs(a[0],0);
                cout<<ans<<endl;
            }
    return 0;
    }
    

      

  • 相关阅读:
    SQL分组统计
    实用DOS命令
    Shadertoy 教程 Part 6 使用光线步进算法创建3D场景
    浅谈web前端优化
    如何搭建一套前端监控系统
    with(this)中with的用法及其优缺点
    vue mvvm
    散列表(哈希表)(二)散列函数的构造方法
    作为程序员,你最常上的网站是什么
    散列表(哈希表)(一)散列表的概念
  • 原文地址:https://www.cnblogs.com/xinxiangqing/p/4693272.html
Copyright © 2020-2023  润新知