• Calendar201307311618.txt


    Calendar
    Time Limit: 1000MS  Memory Limit: 30000K
    Total Submissions: 9817  Accepted: 3684

    Description

    A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system.
    According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years.
    Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.
    Input

    The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer ?1, which should not be processed.
    You may assume that the resulting date won’t be after the year 9999.
    Output

    For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".
    Sample Input

    1730
    1740
    1750
    1751
    -1
    Sample Output

    2004-09-26 Sunday
    2004-10-06 Wednesday
    2004-10-16 Saturday
    2004-10-17 Sunday

    #include "stdio.h"
    int main()
    {
     int a[2]={365,366};
     int b[2][13]={0,31,28,31,30,31,30,31,31,30,31,30,31,
            0,31,29,31,30,31,30,31,31,30,31,30,31};
     char c[7][10]={"Sunday","Monday","Tuesday","Wednesday",
           "Thursday","Friday","Saturday"};
     long n;
       int i,year,month,week;
       while(scanf("%d",&n)&&n!=-1)
       {
           year=2000;
          i=(year%400==0||(year%4==0&&year%100!=0));
          week=(n+6)%7;
          n+=1;
          for(;n>a[i];)
          {
            n-=a[i];
            year+=1;
            i=(year%400==0||(year%4==0&&year%100!=0));
          }
         
          for(month=1;n>b[i][month];month++)
          {
           n-=b[i][month];
          }
           printf("%d-%02d-%02d %s ",year,month,n,c[week]);
       }
        return 0;
    }  
          
          
          
          
            
            
            
            
            
            
            
            
            
            
            
           
          

  • 相关阅读:
    切割窗口url
    软键盘弹出底部被顶上去
    C语言字符串处理标准库函数的源码(转)
    slapd配置文件详述
    OPENLDAP安装配置方法
    const成员函数
    OPENLDAP概述
    当前比较有名的Xml数据库
    『转』使用 Scalable Vector Graphics 为 ASP.NET 构建基于 XML 的灵活、轻量的图像
    SqlCommand_ExecuteNonQuery 方法返回值为1的解释
  • 原文地址:https://www.cnblogs.com/xiaziteng/p/long.html
Copyright © 2020-2023  润新知