• [POJ1936]All in All


    [POJ1936]All in All

    试题描述

    You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

    Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

    输入

    The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

    输出

    For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

    输入示例

    sequence subsequence
    person compression
    VERDI vivaVittorioEmanueleReDiItalia
    caseDoesMatter CaseDoesMatter

    输出示例

    Yes
    No
    Yes
    No

    数据规模及约定

    见“输入

    题解

    求一个串是不是另一个串的子序列,贪心匹配就行了。

    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <cmath>
    #include <stack>
    #include <vector>
    #include <queue>
    #include <cstring>
    #include <string>
    #include <map>
    #include <set>
    using namespace std;
    
    
    #define maxn 100010
    int n, m;
    char S1[maxn], S2[maxn];
    
    int main() {
    	while(scanf("%s%s", S1 + 1, S2 + 1) != EOF) {
    		n = strlen(S1 + 1); m = strlen(S2 + 1);
    		if(n > m){ puts("No"); continue; }
    		int i = 1, j = 1;
    		for(; i <= n; i++) {
    			for(; S1[i] != S2[j] && j <= m; j++) ;
    			if(j > m) break;
    			j++;
    		}
    		if(i > n) puts("Yes");
    		else puts("No");
    	}
    	
    	return 0;
    }
    
  • 相关阅读:
    I帧/P帧/B帧---术语解释
    利用forwardInvocation实现消息重定向
    doubango地址配置
    ARC使用小结
    NSException异常处理
    Runtime of Objective-C
    perl脚本框架整理
    模块——Getopt::Long接收客户命令行参数和Smart::Comments输出获得的命令行参数内容
    Linux学习进阶示意图
    Linux——入门命令
  • 原文地址:https://www.cnblogs.com/xiao-ju-ruo-xjr/p/5807227.html
Copyright © 2020-2023  润新知