• C


    来源poj1182

    动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
    现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
    有人用两种说法对这N个动物所构成的食物链关系进行描述:
    第一种说法是"1 X Y",表示X和Y是同类。
    第二种说法是"2 X Y",表示X吃Y。
    此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
    1) 当前的话与前面的某些真的话冲突,就是假话;
    2) 当前的话中X或Y比N大,就是假话;
    3) 当前的话表示X吃X,就是假话。
    你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。

    Input

    第一行是两个整数N和K,以一个空格分隔。
    以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
    若D=1,则表示X和Y是同类。
    若D=2,则表示X吃Y。

    Output

    只有一个整数,表示假话的数目。

    Sample Input

    100 7
    1 101 1
    2 1 2
    2 2 3
    2 3 3
    1 1 3
    2 3 1
    1 5 5

    Sample Output

    3

    并查集,[https://www.cnblogs.com/haoabcd2010/p/5688902.html]

    比较重要的是在压缩路径的时候要怎么算出他们中间的关系

    #include<iostream>
    #include<stdio.h>
    #include<stdlib.h>
    #include <iomanip>
    #include<cmath>
    #include<float.h> 
    #include<string.h>
    #include<algorithm>
    #define sf scanf
    #define pf printf
    #define mm(x,b) memset((x),(b),sizeof(x))
    #include<vector>
    #include<queue>
    #include<stack>
    #include<map>
    #define rep(i,a,n) for (int i=a;i<n;i++)
    #define per(i,a,n) for (int i=a;i>=n;i--)
    typedef long long ll;
    const ll mod=1e9+100;
    const double eps=1e-8;
    using namespace std;
    const double pi=acos(-1.0);
    const int inf=0xfffffff;
    const int N=50005; 
    int f[N],r[N];
    int find(int x)
    {
    	int fx=x;
    	if(f[x]!=x)
    	{
    		fx=find(f[x]);
    		r[x]=(r[f[x]]+r[x])%3;
    		f[x]=fx;
    	}
    	return f[x];
    }
    bool Union(int d,int x,int y)
    {
    	int fx=find(x),fy=find(y);
    	if(fy!=fx)
    	{
    		f[fy]=fx;
    		r[fy]=(3-r[y]+r[x]+d-1)%3;
    		return true;
    	}
    	if((3-r[x]+r[y])%3==d-1) return true;
    	return false;
    }
    int main() 
    {
    	int n,k;
    	cin>>n>>k;
    	rep(i,0,N)
    	{
    		f[i]=i;r[i]=0;
    	}
    	int ans=0;
    	int d,x,y;
    	while(k--)
    	{
    		sf("%d%d%d",&d,&x,&y);
    		if(x>n||y>n||(d==2&x==y)){ ans++;continue;}
    		if(!Union(d,x,y)) ans++;
    	}
    	pf("%d",ans);
    	return 0;
    }
    
  • 相关阅读:
    接口
    echartsx轴名称过长,截断+鼠标划过显示全称
    浏览器兼容的几点思路
    安装gulp教程(整理)
    TortoiseSVN文件夹及文件图标、标识、绿色小对号不显示解决方法(转载)
    css实现小三角(转载+个人笔记)
    css常用样式(待更新)
    表格样式设计和几点考量
    一些大神或者觉得有益的博客、专栏等(不定时更新)
    搭配bootstracp运用的通用样式(想起来就开个头,待补充……)
  • 原文地址:https://www.cnblogs.com/wzl19981116/p/9438960.html
Copyright © 2020-2023  润新知