• HDU-6033 Add More Zero


    There is a youngster known for amateur propositions concerning several mathematical hard problems.

    Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m1) (inclusive).

    As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1to 10k (inclusive).

    For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

    Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

     


    Input
    The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1m105.
     


    Output
    For each test case, output "Case #xy" in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.
     


    Sample Input
    1 64
     


    Sample Output
    Case #1: 0
    Case #2: 19
     
    有一台计算机,它可以计算从0~2m-1的所有数,一个年轻人喜欢10k,所以他希望你能告诉他在给定的m下,能使10k满足条件的K的最大值。
    差不多这个意思吧...
    那么把10k中k可以看成是2m-1的位数-1。即求解2m-1的位数即可。
    #include<iostream>
    #include<math.h>
    #define LG 0.30102999566
    using namespace std;
    int main()
    {
        int a;
        double m;
        a=1;
        while(cin>>m)
        {
            cout<<"Case #"<<a++<<": "; 
            cout<<(int)(m*LG)<<endl;
        }
    }
  • 相关阅读:
    跳转指定页面
    如何解决项目中.a文件中的.o冲突
    地图根据起点和终点计算中心点角度来绘制弧线 iOS
    codePush常用
    ios原生push到RN界面后pop
    atomic,nonatomic的区别
    KVC
    jQuery绑定event事件的各种方法比较
    Git常用命令总结
    多个$(document).ready()的执行顺序问题
  • 原文地址:https://www.cnblogs.com/wsblm/p/7520605.html
Copyright © 2020-2023  润新知