• POJ


    Wireless Network
    Time Limit: 10000MS   Memory Limit: 65536K
    Total Submissions: 27292   Accepted: 11291

    Description

    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

    Input

    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
    1. "O p" (1 <= p <= N), which means repairing computer p. 
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

    The input will not exceed 300000 lines. 

    Output

    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

    Sample Input

    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4
    

    Sample Output

    FAIL
    SUCCESS
    代码:
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    #include<cmath> 
    using namespace std;
    const int N=1000+5;
    int par[N],rank[N];
    void init(int n)
    {
        for(int i=0;i<=n;i++)
        {
            par[i]=i;
            rank[i]=0;
        }
    }
    int find(int x)
    {
        if(par[x]==x)return x;
        else return par[x]=find(par[x]);
    }
    void unite(int x,int y)
    {
        x=find(x);
        y=find(y);
        if(x==y)return ;
        if(rank[x]<rank[y])
        {
            par[x]=y;
        }
        else
        {
            par[y]=x;
            if(rank[x]==rank[y])rank[x]++; 
        } 
    }
    int main()
    {
        int n,d;
        int x[N],y[N];
        cin>>n>>d;
        init(n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&x[i],&y[i]);
        }
        getchar();
        int vis[N]={
            0
        };
        int v[300000+5];
        int c=0;
        int a;
        char ch;
        while(cin>>ch)
        {
            if(ch=='O')
            {
                cin>>a;
                vis[a]=1;
                v[c++]=a;
                for(int i=0;i<c-1;i++)
                   if((x[a]-x[v[i]])*(x[a]-x[v[i]])+(y[a]-y[v[i]])*(y[a]-y[v[i]])<=d*d)
                   {
                       unite(a,v[i]);
                   }
            }
            else if(ch=='S')
            {
                int b;
                cin>>a>>b;
                if(find(a)==find(b)&&vis[a]&&vis[b])cout<<"SUCCESS"<<endl;
                else cout<<"FAIL"<<endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    FMDB的使用方法(附Demo)
    简单了解SQL(结构化查询语言)
    sql面试题(学生表_课程表_成绩表_教师表)
    iOS
    数据库的关系代数六大基本操作符
    数据库视图
    刚装上最新node,npm install报这个错误!求ndoe大神解答!!!
    手把手教你搭建 vue 环境
    Node.js/Vue环境搭配安装
    CentOS系统下Redis安装和自启动配置的步骤
  • 原文地址:https://www.cnblogs.com/widsom/p/6729833.html
Copyright © 2020-2023  润新知