• B


    这道题可把我憋死了,哎!

    刚開始定义a【15】,执行错误,无语呀。!!!!

    Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

    Description

    As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list 
    1 4 3 2 9 7 18 22

    your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9. 

    Input

    The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

    Output

    The output will consist of one line per input list, containing a count of the items that are double some other item.

    Sample Input

    1 4 3 2 9 7 18 22 0
    2 4 8 10 0
    7 5 11 13 1 3 0
    -1

    Sample Output

    3
    2
    0
    #include<iostream>
    #include <algorithm>
    using namespace std;
    int main()
    {
    	int a[100],i,n,j,k;;
    cin>>a[0];
    	while(a[0]!=-1)
    	{
    	i=1;
    	
    	n=0;
    
    
    	while(a[0]&&cin>>a[i]&&a[i])
    	{
    		i++;
    	}
    
    	for(j=0;j<=i;j++)
    		for(k=j+1;k<=i;k++)
    			if(2*a[j]==a[k]||a[j]==2*a[k])
    			{n++;}
        
    
        cout<<n<<endl;
    	cin>>a[0];
    	}
    
    return 0;
    }
    


  • 相关阅读:
    [转载]使用uiautomator做UI测试
    [转载]Android相关开发网站
    [转载]Android开发必备的21个免费资源和工具
    c# List集合的Find方法适用
    c# GridView Footor列求合计
    c# List集合排序
    mysql中插入多条记录-微软批处理
    mysql中插入多条记录-微软批处理
    VS2005快捷键
    LinqToSql 小例子
  • 原文地址:https://www.cnblogs.com/wgwyanfs/p/7379981.html
Copyright © 2020-2023  润新知